4

I'm trying to install the Windows 10 Technical Preview from a USB drive.

The hard drive I'm trying to install on has multiple partitions and is formatted with a GPT partition table. When I start up the Windows 10 TP custom install I get as far as selecting my partition, and then it won't go any further. The installer gives me an error that says "Windows cannot be installed on this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only installed on GPT disks."

But my disk is GPT! When I formatted it, I made sure to make it GPT. Checking it with Gparted in a Linux lives session shows me that the disk is GPT.

Why is Windows failing to recognize that my disk is GPT? And how can I fix it?

  • 2
    how did you create the USB device? Try rufus and select UEFI/GPT: rufus.akeo.ie Also in the bootmenu of your PC, select UEFI mode. – magicandre1981 Jan 16 '15 at 6:17
  • On most new laptops with UEFI I've tried, I've had a lot of trouble installing Windows off of a USB key - I've had luck by copying the install files to the HDD itself and then launching setup again from there, or by using a DVD, however. – Breakthrough Jan 16 '15 at 6:20
4

Turns out this problem is caused by trying to install Windows on a GPT disk with USB install media formatted with MBR.

Thanks to a suggestion by @magicandre1981, I created my USB install media with rufus, taking care to select the "GPT partition scheme for UEFI devices" option, booted into the USB drive in UEFI mode, and was able to install Windows properly.

  • Using rufus with MBR partition scheme for BIOS or UEFI worked for me. – Alireza Mirian Sep 9 '16 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.