0

I have two 4TB WD RED HDDs in a machine running Ubuntu 14.04. One drive is perfectly normal, but the other one does not allow writes. The error says Read-only file system (30) in Midnight Commander.

enter image description here

I tried replacing it with another identical WD RED HDD, but it still started giving the same error after a few successful writes.

I also tried formatting the drive with NTFS and using it under Windows. It did not seem to have any problem, allowing me to write 2.5TB of file onto it.

The drive in question has one primary ext4 partition.

Is something wrong with the drive's hardware? Or is it something else? Any ideas will be appreciated.

  • are you running the 32-bit or 64-bit version of Ubuntu? – user409554 Jan 17 '15 at 15:08
  • check the system log viewer after connecting the drive or just copy the relevant part from file /var/log/syslog and paste it here... – Vitas Jan 18 '15 at 20:00
0

Normally you will face this issue due to the file system of the drive. It is recommended not to have file NTFS file in Linux. Try to format the drive to ext4 or xfs file system and check

  • As I wrote, the drive in question has one primary ext4 partition. I only tried it with NTFS under Windows to see whether it is a hardware issue. – Roman Mironov Jan 17 '15 at 10:12
0

If system encounters errors on linux supported fs (not ntfs) it remounts the disk as read only (/etc/fstab option: errors=remount-ro). The behavior for ntfs is undeterministic and writing might cause corrupted files on disc.

Possible explanations:

  • The both disks are failing (That's not really likely)
  • The disk (SATA?) controller might be failing

Try to reconnect the disk to different controller (or machine).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.