1

Trying to use OpenWRT as a DNS server for local names. i have set my adsl router up as dhcp server and using the OpenWRT router as the primary dns server with google (8.8.8.8) as the secondary DNS server.

I have added 'router' 192.168.1.1' to the hostnames section of LuCI.

I can ping using cmd '192.168.1.1' and it replies correctly. I can browse to 'h t t p://192.168.1.1' using a web browser. I can ping using cmd 'router' and it resolves correctly. I cannot browse to 'h t t p ://router' using a web browser. I can ping using cmd 'router.lan' and it resolves correctly. I cannot browse to 'h t t p://router.lan' using a web browser.

Edit

Using windows 7, with chrome, IE, and firefox. Using Android with chrome,

The error chrome gives is Error code: ERR_EMPTY_RESPONSE

NOT Error code: ERR_NAME_NOT_RESOLVED

  • It might help if you specify which OS and web browser you're using on your client. – Spiff Jan 17 '15 at 3:55
  • Have you set "Intercept DNS port (UDP 53)"? – Romeo Ninov Jan 17 '15 at 9:23
  • Sounds like you are connected to the adsl router, and you are trying to give your openwrt router a name to resolve? If so, then you need to configure the dhcp option and add the hostname on the adsl router, not on the openwrt. – Sean Lee Jun 5 '16 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.