0

I purchased the server version of JIRA Agile and have it running on my Windows 8.1 x64 machine. I have the Catalina service in conf/server.xml file set to port 8100. I also modified the Windows firewall rules: there was one already in there for Jira which allowed private access; I updated that to allow public access as well. In addition to that, I created a new Windows firewall rule to open up all traffic on port 8100. Finally, my network is behind a Linksys WRT54G2 router, and locally the box running Jira is on IP address 192.168.1.109. So in my router settings, I have port 8100 forwarding to that IP address.

enter image description here

I am able to access Jira on that machine, but not on any other on my network. On that box, I can access it successfully in any of the following three ways:

  1. http://localhost:8100
  2. http://127.0.0.1:8100
  3. http://192.168.1.109:8100

All three work just fine when I'm on that box. But if I try to access 192.168.1.109:8100 from another machine on my LAN, it times out / never connects. This is particularly strange because when I first set it up last week, I was able to connect to Jira from another machine on my LAN. And, as far as I can tell, I haven't changed any settings since then.

I also ran netstat -a to see what ports were being listened on, and this was one of the line items:

Proto  Local Address  Foreign Address  State
TCP    0.0.0.0:8100   WINSERVER:0      LISTENING

And just to be thorough, I'll copy the contents of my server.xml file here as well:

<?xml version="1.0" encoding="utf-8"?>
<Server port="8005" shutdown="SHUTDOWN">
<Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on"/>
<Listener className="org.apache.catalina.core.JasperListener"/>
<Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"/>
<Service name="Catalina">
<Connector port="8100" maxThreads="150" minSpareThreads="25" 
  connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192"
  protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" 
  acceptCount="100" disableUploadTimeout="true"/>
<Engine name="Catalina" defaultHost="localhost">
<Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true">
<Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">
<Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction" 
  factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/>
<Manager pathname=""/>
</Context>
</Host>
<Valve className="org.apache.catalina.valves.AccessLogValve" resolveHosts="false" 
  pattern="%a %{jira.request.id}r %{jira.request.username}r %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot; &quot;%{jira.request.assession.id}r&quot;"/>
</Engine>
</Service>
</Server>

Any ideas?

4
  • is there a firewall running on the box? – txtechhelp Jan 17 '15 at 21:43
  • Shouldn't be. Like I said, I have the Windows firewall set to open port 8100, and the program entry for Jira is also set to public. – soapergem Jan 17 '15 at 21:44
  • Sorry, missed that part .. 2 things I would try: disable the firewall completely on that box and see if you can make it through that way .. also disable the port forwarding on the router, the port forwards is meant for external forwarding (i.e. I want to connect to your Jira box from outside your network over port 8100, the router will send all requests to the IP specified) – txtechhelp Jan 17 '15 at 21:51
  • Thank you! This led me to figuring it out. I'll put the resolution as an answer below. – soapergem Jan 18 '15 at 20:17
0

txtechhelp's comments helped me figure it out. When I disabled Windows Firewall completely, I was able to successfully access Jira on my LAN. So, clearly, it was a Windows firewall issue. I discovered that I had mistakenly opened UDP port 8100 instead of TCP. Once I changed that, it works fine with Firewall on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.