1

Microsoft Office 2007 comes in different languages. This includes different formula names in Excel, e.g. =Summewenn instead of =sumif. This is quite inconvenient if you're used to the English names or your training material uses those.

I have a German Windows 7 and Office 2007 Professional Plus because I bought them in Germany. I would like to change as much as necessary to English in order to get English Excel formulas and preferably also menu items.

I went to Excel Options/Language Settings (Spracheinstellungen) - this is the same as what you get through Windows Start/Microsoft Office Tools. There was no Display Language tab and no check box to uncheck to use the Windows system language. On the tab "Bearbeitungssprachen" I was able to select English (US) as primary interface language. This setting had no effect whatsoever.

After some research, I tried the following Registry changes:

  • HKCU/Software/Microsoft/Office/12.0/Common/LanguageResources
    • set UILanguage to 0409 - changed back to 0407 at start of Excel
    • set InstallLanguage to 409 - no effect
  • HKLM/System/ControlSet001/Control/NIs/Language
    • set (Standard) to 0409 (from no value) - no effect
    • set Default to 0409 - remains so but has no effect
    • set InstallLanguage to 0409 - changes back to 0407 at boot

0407 is the language code for German, 0409 the one for English.

I also tried to uninstall and reinstall Office but there is no option to change the language.

What do I need to do in order to get English formulas and preferably menus?

2

You need a language pack, which unfortunately are no longer for sale (according to a blog) for office 2007. Your best bet is a new Office license.

1

If you do not find the Display Language tab the language you want is not installed. With Vista I copied the 1033 file from my laptop which had it and pasted it next to to the 1043 file in "programs".

Next is a registry change:

  • Run "regedit" and look for: HKEY_CURRENT_USER\Software\Microsoft\Office\12\Common\LanguageResources (The above "12" is for 2007, you do not mention your system version)
  • You will see possibly three codes: (Default), 1033 and another that you are trying to set.
  • Right click the Default and 1033 (English US) and change to Off.
  • If the language code that you do want is not there, right click Enabled Languages, New, String Value and type in the code (from the website above) and type On in the Value Data.

I would then do a reboot to reset everything, now in the LanguageRegion Settings either the langauges are not showing or you can now remove them and they should remain removed.

Please note that 1033 is English(US) 1043 is dutch, you should see the german number

1
  • You won't be able to manage the copied files from appwiz.cpl, but this is the next best thing. Most importantly, this shows the underlying mechanism. – ivan_pozdeev Apr 25 '17 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.