Has anyone gotten any of those older LIDE scanners (models 20, 30, 35 etc.) to work on Win7 x64??

I've tried several things, like grabbing the LIDE 60 driver for Vista64, but nothing has worked so far....

Any ideas? Doesn't look like Canon wants to support its "more-than-six-months-old" own hardware.... disappointing, really.

  • Did you try the lide25 drivers?
    – Moab
    Sep 18, 2010 at 22:41
  • 2
    Your little dig on Canon for not supporting this scanner is a bit childish. The LIDE 30 was first available in 2002. That makes it almost 10 years old which is quite a bit more than your "six-months-old" quip and an eternity in the computer hardware world. Jan 23, 2011 at 18:24
  • 4
    @Ryan, your comment is reasonable, but it still worries me. There are cars that still work after 30 years, and buildings still standing after 500. Cars and buildings are very complex and require constant maintenance, just like computers. Do we really want to condone the practice of making hardware so disposable?
    – Max Cantor
    Feb 23, 2011 at 2:57
  • 1
    @Max Apparently "we" do because the majority of the population chooses to buy things based on cost instead of quality or longevity. But in the context of this question, it's irrelevant since his scanner is still working. It's just not supported on modern OSes because Canon doesn't want to spend money supporting hardware they don't even sell anymore. In relation to your analogy, it would be like asking Ford to build an Ethanol conversion kit for a 1981 Fairmont. Feb 26, 2011 at 8:00

5 Answers 5


Download the evaluation version of VueScan (www.hamrick.com) and install that scanning software. This will install 64 bits support for Windows 7. Purchase of the software is not required, as soon as the VueScan drivers are in place the Lide scanner can be used with any software on your computer intefacing the scanner. Also works for Lide 30 (and other Canon scanners not directly supported by Canon).

  • excellent, great to know, thanks - I'll try that asap.
    – marc_s
    Jan 13, 2010 at 16:06
  • 1
    Worked like a charm for a CanoScan20 in Win7 x64, as well. Sep 23, 2010 at 16:54
  • Also works when there are no Windows 8 drivers yet, e.g. with the Canon CanoScan LiDE 25. But the shareware notice can only be removed by purchasing VueScan.
    – Michael S.
    Mar 16, 2012 at 15:27

If they have a Windows Vista driver, you should be able to manually install that... Extract all files, then in Device Manager, right click on the device and during the install driver, point to the directory with the extracted files.

As I answered in someone else's question. With old unsupported hardware, if you cannot find a newer driver, the other thing to always try is to install it inside a virtual machine. Look here for more information.

  • 1
    Thanks for your answer - the Win7 VirtualXP Mode doesn't seem to work on my 3yr old Dell Dimension 9100, so that's out the window :-( I tried to install their 64-bit Vista drivers, but somehow, the install just silently fails and gives no indication as to what's wrong with it :-(
    – marc_s
    Dec 22, 2009 at 21:36
  • Try my method of installing the drivers - extract everything to a folder (You want the .inf file) then in device manager, manually right click on the Unknown Device / scanner with an exclamation mark and manually install the driver pointing to the directory with the .inf file. If this still does not work, you can try Virtual Box as it is free ( www.virtualbox.org ) or my favourite - VMware Workstation ( vmware.com/products/workstation ) Which costs, but costs a bit. Dec 22, 2009 at 21:45
  • @Wil: I tried that too - but when I right-clicked on the .INF to install, it complained that this product didn't support this method of installation or something like that :-(
    – marc_s
    Dec 23, 2009 at 7:34

The only way I managed to use my Lide 20 scanner in Vista x64 was from inside an XP x86 virtual machine (VMware).

Shame on you, Canon.

  • +1 indeed - Canon is pretty bad that way. Makes me wonder if I should be a new WIn7-x64 capable scanner from another vendor....
    – marc_s
    Dec 22, 2009 at 21:35
  • Seems the LIDE 30 is officially on the "not compatible" Windows hardware list :-( No hope there .....
    – marc_s
    Dec 26, 2009 at 21:27

I found out that Ubuntu 10.10 supports the scanner, and you don't have to install it either, you can just run it off of the live CD (takes a few minutes to boot). It should detect the scanner and allow you to access you HD without installation.

hardware/software: LIDE 30 with Windows 7 64-bit.


Did you try the LiDE 60 drivers for Windows 7 64 bit? They worked for me when I tried them on the following thread.

Not the answer you're looking for? Browse other questions tagged or ask your own question.