I am using windows 8.1 64 bit

I am unable to remove the read only attribute on folders on my computer. I have tried multiple folders on my desktop, and in my documents folder, if I uncheck the read only box and hit apply, then close and reopen the properties window, the box is checked again. This applies to all folders I have checked. How can I allow full read and write privileges to these folders?

marked as duplicate by Ƭᴇcʜιᴇ007, magicandre1981, DavidPostill, Mokubai Jan 19 '15 at 21:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 8 down vote accepted

At the filesystem level, both files and directories have a "read-only" attribute. Both can be set using the attrib command from the command line. However, from within the Windows GUI, the read-only attribute cannot be adjusted for directories, only for files.

When Windows presents a directory as a folder within the GUI, the +r flag is only used to determine whether that folder has been customized or not, e.g. with a background. Other than that, this flag is ignored by Windows and this flag is not displayed for a folder anywhere in the GUI. Folders can be deleted and written to regardless of this flag because Windows doesn't care about this flag when it comes to deleting or writing to the folder.

The only exception to this appears to be when an attempt is made to delete the folder using the 'rd' command from the command line. This is the only case where the +r flag on a directory is honored by Windows for it's named purpose.

This KB article is for earlier versions of Windows, but still applies: http://support.microsoft.com/kb/326549

As indicated by the folder properties dialog box, this check box in the GUI indeed only applies to files:

Folder Properties Dialog Box

This check box has three states:

  • A square: The state that is shown every time the properties dialog box for any folder is opened. All folders show this state when the dialog box is opened and no changes are made. When the checkbox is in this state, it tells Windows to do absolutely nothing to the read-only attribute of files when APPLY or OK is pressed.
  • A checkmark: When this state is selected, it directs Windows to set the read-only flag on every single file within the folder when APPLY or OK is pressed.
  • Cleared/No Check/No Square: When this state is selected, it directs Windows to clear the read-only flag on every single file within the folder when APPLY or OK is pressed.

So from within the GUI, the ability to write to and delete files is controlled through both NTFS permissions and the read-only flag. Folders, on the other hand are controlled through NTFS permissions only as detailed in the previous answer.

  • The attrib <dir> command (with no -r) shows there is no "R" on the folder yet it shows the half gray (win8pro). – crokusek May 19 '16 at 0:07

Follow the steps below to grant you full access to folder.

  1. Right-click the folder - Properties.
  2. Security tab - Advanced.
  3. Click Change to the right of Owner.
  4. Enter Users into box and click OK.
  5. Enable the checkbox Replace owner on subcontainers and objects then click Apply.
  6. If prompted that You do not have permissions to read.. click Yes.
  7. Completely close out of the Advanced Security Settings dialog.
  8. Right-click the folder - Properties.
  9. Security tab - Edit.
  10. Add...
  11. Enter Users into box and click OK.
  12. Enable the Full Control checkbox then click OK.

Or using the attrib command, open a Prompt Command as Administrator and execute the following command:

attrib -r c:\foo

Replace c:\foo for the your folder. For more information here.

  • 3
    I followed your instruction exactly, and I am still having the same problem. – user3308082 Jan 18 '15 at 1:03
  • 1
    @user3308082 Try the using attrib command. – stderr Jan 18 '15 at 1:22
  • The attrib <dir> command (with no -r) shows there is no "R" on the folder yet the checkbox shows the half gray (win8pro). – crokusek May 19 '16 at 0:08
  • This ALMOST worked for me... the key for me was in the 'Advanced' dialog... unchecking the 'inherited permissions' and telling it to 'Remove' when a pop-up asked me to confirm. After this I had to add my user to the folder's permissions, and everything seemed OK then. – nmz787 Aug 15 '16 at 18:15
  • This answer helped me resolved the issue -- not the selected one unfortunately – qodeninja Mar 7 at 1:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.