2

I need to connect a Linux Fedora 21 desktop to a L2TP over IPSec VPN. I was given a set of instructions for how to do so on a MAC as that is what they use but I have been unable to do so on Fedora. Here are the instructions I was given:

  1. Open System Preferences
  2. In the bottom left pane, click the +
  3. Select VPN as the interface type
  4. Select L2TP over IPSec as the VPN Type
  5. Set the service name to "Some company name"
  6. Set the server address to: x.x.x.x
  7. Account Name: xxxusername
  8. Password: xxxpassword
  9. Shared secret: xxxsharedsecret

Now I've searched a bunch for this but nothing I have tried has worked yet.

In particular I have the following package installed via yum:

NetworkManager-l2tp.x86_64

In the Network Manager GUI I created the VPN connection via:

  1. Add Network Connection
  2. VPN
  3. L2TP...
  4. Settings:
    1. Name: "Some company name"
    2. Gateway: x.x.x.x
    3. Username: xxxusername
    4. Password: xxxpassword
    5. NT Domain: blank
    6. Firewall Zone: Default
    7. Not available to other users
  5. Then IPSec Settings:
    1. Checked Enable IPSec...
    2. Group Name: "Some company name"
    3. Gateway Id: blank
    4. pre-shared key: xxxsharedkey

Any ideas what I am doing wrong and why I can't connect? One thing to note which I don't think is a problem is the company name string does have a space in it.

Double props to whomever has a solution which allows me to connect that's just via the command line/editing text files as well.

  • Do you get any error messages or repeat notifications? What happens if you change the settings to allow for all users? – rickhg12hs Jan 24 '15 at 0:42
  • This seems like a very detailed guide : L2TP/IPSec VPN client on Fedora and is even pretty recent. – harrymc Jan 24 '15 at 19:54
2
+100

There is a very detailed cookbook guide in this article : L2TP/IPSec VPN client on Fedora.
It is even pretty recent, from October 1, 2014.

It lists the packages to install :

libreswan
xl2tpd

And the files that require editing :

/etc/ipsec.d/desired_vpn_name.conf
/etc/ipsec.d/desired_vpn_name.secrets
/etc/xl2tpd/xl2tpd.conf
/etc/ppp/options.xl2tpd.VPN_CONNECTION_NAME
/var/run/xl2tpd/l2tp-control

(The article is pretty much to the point, so no reason to reproduce it here entirely.)

  • I had previously seen this but it turns out I had made some errors. The main being the ipsec.conf file doesn't include the ipsec.d config files by default. I've got it working now. – David Mokon Bond Jan 25 '15 at 4:29
  • 1
    For anyone who is reading this and wants to do the same thing here is a script I made that does the above. github.com/Mokon/menv/blob/master/bin/ipsec_l2tp_vpn I gladly accept pull requests that improve the script... – David Mokon Bond Apr 5 '15 at 13:37
1

run the following as root.

    cd /etc/yum.repos.d/
    wget http://download.opensuse.org/repositories/home:wejaeger/Fedora_16/home:wejaeger.repo
    yum install l2tp-ipsec-vpn
  • it should work with later versions of Fedora, so dont mind it saying Fedora 16. – bret7600 Jan 21 '15 at 2:03
  • thanks but I had trouble going this route. There was some dependency issues that I never resolved as that repo doesn't contain everything it needs. – David Mokon Bond Jan 25 '15 at 4:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.