0

I recently bought a computer that came with an AsRock Extreme 9/ac motherboard - which I am adoring and love in every way. Everything about it works just fine.

I install Windows (8.1 x64) and go through all of the driver installs just fine. I can connect to the internet via a wired LAN line without any problem. All of the drivers check out, things work splendidly.

But for some reason, the WiFi adapter built into the motherboard behaves strangely. It works - it is there, it SEES the networks, it tries to connect to them, but it keeps saying that it can't after I give it valid passwords.

I know that it is not an invalid password. I also know that the router is fine, because other devices (Microsoft Surface Pro 1, NEST Thermostat, Samsung Smart TV, Roku, Nexus 7, Nexus 6 phone) can connect to it just fine wirelessly.

Also, the PC with the AsRock motherboard was able to connect to an older NETGEAR router I had for a time - but I no longer have that either. It is as if the WiFi Adapter works "enough" to see the networks, but then cannot do anything beyond that.

I would assume it is the router, but since other devices connect fine, I have to rule that out. I've tried other wireless routers or wireless trasmitters to connect to and cannot link to them either, such as the TP-LINK TL-WR710N from TP-LINK, and cannot connect to it either - but again, it can see the device just fine, and see its signal strength, and see that it has a protected password.

I've tried uninstalling the drivers and reinstalling the newest from AsRock's website. I've tried the default install that shipped with the PC (It is an ORIGIN GENESIS PC). I've tried using Windows 8.0 x64 drivers instead of the Windows 8.1 x64. I have tried using the 32-bit drivers. I have tried updating the BIOS to 2.30, I have tried downgrading the BIOS down to all previous versions as well. I have tried having AT&T change my router multiple times, as well.

The AT&T Router that I am trying to connect to is a MOTOROLA NVG589.

Any help is greatly appreciated, because I am totally at a loss for anything more I can try at this point.

  • 2
    In whatever software it is that you use to connect to the router, do you get an option to use (or force) 802.11n instead of 802.11ac? Do you have a USB wireless adapter that you can try with temporarily? I guess that as you have changed the router that you have not set up a MAC address restriction policy on it and forgotten that you did so. – Andrew Morton Jan 18 '15 at 18:42
  • I don't use any software, I use the default tools in Windows 8.1 - the ones that appear on the right side of the screen kind of like the charms bar. – Derek Jan 18 '15 at 18:47
  • A USB Wireless adapter? I can see if I can dig one up, sure. Not certain if I have one though. But I'll look. – Derek Jan 18 '15 at 18:48
  • 1
    Hmm... thinking about it more, I suspect that even if you get a connection with the USB wireless adapter, it will get you no closer to solving the problem. There are a few things to try suggested by the results of searching (Google) for "windows 8.1 problem connecting to wifi". – Andrew Morton Jan 18 '15 at 19:08
  • 1
    Have you checked Device Manager | Network adapters? You can check its Properties and try to find newer drivers. The Advanced tab has a slew of settings, perhaps someone with the same WiFi adapter can show you a list of what they should be. – DrMoishe Pippik Jan 19 '15 at 0:41
0

As the Motorala NVG589 does not work with 802.11ac wireless, you could force the computer's adapter to use 802.11n to avoid any possible confusion with protocol negotiation failures.

It is possible to buy an 802.11ac wireless router and use the NVG589 in pass-through mode, as mentioned at http://forums.att.com/t5/Equipment/Wireless-A-C/td-p/3864591.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.