0

I'm trying to change the Apache root directory from

/Users/"my user"/applications/XAMPP/htdocs

to a

/Users/"my user"/dropbox/sites

directory, so that my files automatically back up to Dropbox. However, after restarting the server within XAMPP I am getting an "Access denied! There is no index...." error.

  • Macbook Pro, OSX Mavericks
  • XAMPP latest edition

here is my https.conf, part regarding the document root:

# DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs"
DocumentRoot "/Users/edchigliak/dropbox/sites"
<Directory "/Users/edchigliak/dropbox/sites">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important.  Please see
# http://httpd.apache.org/docs/trunk/mod/core.html#options
# for more information.
#
#Options Indexes FollowSymLinks
# XAMPP
Options Indexes FollowSymLinks ExecCGI Includes

#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
#AllowOverride None
# since XAMPP 1.4:
AllowOverride All

#
# Controls who can get stuff from this server.
#
Require all granted
</Directory>

As you can see I just commented the first line # DocumentRoot, copied it into the next line and changed the path. Below that, I also copied the right path wanting to grant permissions to the new root directory. SOmething has gone wrong along the way :))

Any ideas?

0

The user that Apache is running under won't have access to the home directory of a specific user by default, you'll need to grant that access for this to work.

  • A-ha! That is the problem... Can you help out with the directives/code? I really do very little server administration, if any so I'm not really knowledgeable on this. Thanks! – Alex Starbuck Jan 17 '15 at 19:35
  • @AlexStarbuck I'm not sure exactly how that needs to look on an OS X server, but, it looks like you'll need to grant the _www user access to the directory - seems like something you'd be able to do in the permissions UI, or do something like this. – Shane Madden Jan 17 '15 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.