Windows 8.1. Admin account.

I have a hard drive installed that I use for media (ie. not system files, etc). I was testing various screen capture programs and one of them created a couple of folders that I now can't get rid of.

In the past when I run into this kind of problem, it is fixed by either changing the permissions or, when that fails, taking ownership and then changing the permissions. But in this case, it won't even let me do that!

Right-Click -> Properties -> Security:

You must have Read permissions to view the properties of this object

OK, so click Advanced. Can't do ANYTHING.

Beside "Owner" is:

Unable to display current owner _Change

Clicking Change yields:

You do not have permission to view or edit this object's permission settings

No option to do anything!

I'm really having a wtf moment and could use some help.

I can't even tell how much room these things are taking up as it won't even give me that information!

Edit: I think I've determined that it was the program Camtasia which did this. I installed their trial software and subsequently removed it after determining it wasn't what I was looking for. Looking at their forums I see mention of these folders, but the answer is that they "should" auto remove on their own. No suggestions on how to get rid of them.

  • Seems simple, but have you tried rebooting yet? – Ƭᴇcʜιᴇ007 Jan 19 '15 at 5:27
  • Well... err... no, no I haven't :) Also could try booting into Safe Mode. Haven't had to do that in years so kinda forgot. Always forgetting the little things :) BRB – bcsteeve Jan 19 '15 at 6:50
  • Man, now I feel duuuumb. Thanks for your help, rebooting did it. And during the reboot process I saw why. A rogue process from that uninstalled program was still running, no doubt locking those folders. Still, strangest permissions issue I've ever run across. – bcsteeve Jan 19 '15 at 6:52
  • I had the same problem, but rebooting didn't work. Luckily I had a Linux PC at hand. For those who don't have (live) Linux but have a space USB stick, you can make one in 5 minutes: ubuntu.com/download/desktop/create-a-usb-stick-on-windows (choose lubuntu) – Mark Jeronimus Aug 29 '15 at 19:59

The file is probably actually deleted, but a handle to it is locked in memory someplace and won't release until the system is shutdown.

Simplest thing to try first: Reboot the system.

Once it's done rebooting, see if the file still exists and if it does try deleting it again.

If you're still having problems after that, then perhaps check out the answers at this SU question:

  • Finally, I was unable to delete Steam games backup (the Disc_xx subfolders). Thanks for this tip! – Petr Újezdský Jan 5 '17 at 18:33

You could try using a Live Linux distro.

Basically every Linux distribution nowadays comes with a bootable live medium; with it you can run the whole system /from a CD/DVD, an USB pendrive, and so on) without the need of installing it on your hard-drive.

Since it is a different system it won't follow Windows' administration setting, and you can easily delete these folders.

You can choose the Distro that you prefer, it doesn't matter. You can just go to its site, donwload the ISO image and burn it to a CD/DVD or USB pendrive. A fastest way, however, could be to use UNetbootin, it is an application that runs also under Windows and automate all the procedure for you.

Once your bootable media is ready, run it and delete those folders from within Linux.


I found this solution on Microsoft forum. and I worked with me!

Registry Disclaimer: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/ )

  1. Press Windows logo key on the keyboard, type Regedit and select the top most search result.
  2. Right click on HKEY_LOCAL_MACHINE and click on Permissions from the context menu.
  3. From the window, click on Add under Group or user names.
  4. In the window, type Everyone under Enter the object names to select and click on Check names.
  5. Once the group is available, click on OK.
  6. Click on Everyone from the window and click on Full control under Permissions for Everyone.
  7. Click on Apply and OK.
  8. Close the window and check if the changes are effective. In my case, I restarted the explorer process from the task manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.