I have 105/10 internet through Comcast and I have a TP-LINK WR841N router. I use Ethernet and Wi-Fi. I get ~100Mbps through Ethernet, and only around 10 Mbps through Wi-Fi. Yesterday I had ~50Mbps on Wi-Fi but even that is half of of the original speed. Any suggestions? This really sucks as this router was rated really high by a lot of users.

Here are some details:

Hardware Version:

  • WR841N v9 00000000

Firmware Version:

  • W3.16.9 Build 141013 Rel.61626n


  • Wireless Radio: Enable
  • Name (SSID): Motorola
  • Mode: 11bgn mixed
  • Channel Width: 20MHz
  • Channel: 11
  • WDS Status: Disable
  • How fast a Wi-Fi connection can go depends on the capabilities of both the AP (wireless router) and the Wi-Fi chipset in the client device. What Wi-Fi card or chipset do you have in the client device in question? And what is the client device exactly?
    – Spiff
    Jan 20, 2015 at 7:08
  • It may be the king of the "$20 or free-after-rebate" APs, but you get what you pay for. Vendors have to cut corners like crazy in the race to the bottom of the pricing structure. I find it's better to "invest in" a flagship (but not bleeding-edge) AP, where vendors compete on performance/range/quality/features, instead of buying a bargain-basement AP where they only compete on price.
    – Spiff
    Jan 20, 2015 at 8:00
  • @Spiff It’s not really that bad. With OpenWrt, it’s a capable device, stable too. I can’t check the actual WiFi performance now though, because it’s installed at my parents’ house.
    – Daniel B
    Jan 20, 2015 at 8:14
  • @DanielB It may be "a capable device" by early 2007 expectations, perhaps, but not by 2015 (or even mid-2013) expectations.
    – Spiff
    Jan 20, 2015 at 9:08
  • @Spiff I don’t quite get what you think is wrong with its WiFi performance, because apart from 11ac nothing has changed at all. 11n is still 11n and 2.4 GHz is still 2.4 GHz. Sure, there may be 3×3 MIMO, but clients have to support it, too. Most don’t.
    – Daniel B
    Jan 20, 2015 at 9:16

4 Answers 4


In ideal conditions, such as a perfectly interference-free channel and a good client just 2-3 meters away, you should be able to get over 200Mbps of TCP/IP throughput out of an AP that does the 300Mbps flavor of 802.11n.

From the information you've given, one obvious thing to try is to set the channel width to 20/40MHz instead of 20-only. Your AP can only do 144.4 Mbps signaling when limited to traditional 20MHz-wide channels. To get its 300Mbps max rate, it has to use 40MHz-wide channels.

However, you should beware that the 2.4GHz band is often congested (other Wi-Fi users, Bluetooth, cordless phones, microwave ovens, wireless security cams/webcams, baby monitors, non-Bluetooth wireless mice and keyboards, wireless speakers and subwoofers, Nintendo Wii remotes, etc.), and trying to find a clean contiguous 40MHz-wide swath of that band is more than twice as hard as finding a clean 20MHz-wide swath.

Side note: Because Apple likes to leave some room for Bluetooth devices to have a fighting chance of working well, Apple has traditionally limited all of their 802.11n and 802.11ac-capable devices to using only 20MHz-wide channels when operating in the 2.4GHz band. They still use 40MHz or 80MHz wide channels in the 5GHz band. So if your client device in question, is, say, a MacBook, then setting your WR841N to 20/40MHz mode won't help, because your WR841N only supports the 2.4GHz band. You'd want to replace it with a simultaneous dual-band (a.k.a. dual-band concurrent) AP.

If enabling 20/40MHz mode doesn't solve the problem, here are some other things to try:

  • Make sure your client is capable of the 300Mbps flavor of 802.11n in the 2.4GHz band (2 spatial streams, short guard intervals, 40MHz-wide channels).
  • Make sure your AP is set to use the cleanest possible 40MHz swath of the 2.4GHz band. Try other channels; try turning off other things that could be generating 2.4GHz RF noise; use a tool like inSSIDer to see how neighboring Wi-Fi networks might be interfering with you; etc. If you bought a $20 AP, I'm not going to tell you to spend many times that buying a Wi-Spy or other 2.4GHz spectrum analyzer, but I love my Wi-Spy dBx.
  • Try turning off other things that may be making traffic on your home network, especially if they're older 802.11g or especially 802.11b gear. It's a myth that the presence of those things will drop the whole network down to the old low speeds, but those old devices can consume a lot more wireless airtime for the same amount of traffic, and the modern devices take a performance penalty by having to use various protection mechanisms to keep the older gear from stepping on modern transmissions they can't detect.
  • Make sure your client is 2-3 meters from the AP (too close can overload the radio and cause distortion; too far and you signal strength might no be enough to sustain the top data rates).
  • If you have wireless security enabled, make sure it's WPA2. 802.11n requires WPA2 if you're going to use security. The original WPA, and WEP before that, used hardware RC4 cipher engines that couldn't keep up with 802.11n-era data rates.
  • Make sure you have WMM (a kind of wireless QoS) enabled on both your AP and client, if they give you the option. 802.11n requires WMM. If you disable WMM, you're effectively disabling 802.11n. Some APs and clients aren't smart enough to warn you about that. If they don't give you an option to enable/disable WMM, they must have it on by default which is great.

note that it's probably not related to your internet.

it may related to the wireless bandwidth (mixed mode bgn), since "wifi standard" 802.11b have bandwidth only 10Mbps 802.11g have 54Mbps, and 802.11n have 600Mbps. note that it's just the theoretical bandwidth the actual may lower at 80%ish. edit: duplex communication means it's halved from the bandwidth

meanwhile LAN (fast Ethernet i reckon) have 100Mbps bandwidth.

it's normal that wifi speed is slower than ethernet

try copying between computers (from ethernet to wifi) to check the maximum possible transfer there. and compare it with your current bandwidth. edit: try to change the mode to 11n only and retest if there's actual change (only if your PC/laptop/phone have 11n support)

  • The only option is 11bgn and 11bg . Unfortunately, there does not seem to be an option only for 11n. Jan 20, 2015 at 5:43
  • 3
    This is probably what's causing the horrendously slow speeds. If you have any B devices connect, that's gonna kill your G speed. There's no option to disable mixed mode? Aside from that, the only thing you can do is keep B devices off your network. Also, run InSSIDer to check the surrounding wifi channels and make sure channels 7-11 are as clear as possible (channels 7-10 partially overlap with 11), otherwise, change to 1 or 6.
    – Bigbio2002
    Jan 24, 2015 at 16:30

I had faced a similar problem with my new router 940N (450Mbps N-Router) when using with my BSNL-FTTH 50Mbps Fiber connection.

From the LAN on the router I could get >50Mbps but over Wi-Fi it was simply limited to a slower speed of 20Mbps for some reason.

I tried with multiple devices and they all showed the same slow speed of 20~25Mbps downloads/uploads.

I had contacted the TPLink Tech-support but could not get this solved over remote/Tele-call.

The next day after a few trials of my own I finally found the root-cause and solved it and its been working great since then.

The solution that worked for me:

  • Since this is an N-Router, at the Wireless security settings, TP-Link Setup wizard itself recommends not to set TKIP Encryption but my BSNL technician did set TKIP wrongly during installation.

  • Upon finding this info from the Wireless Security settings page itself, I tried changing it back to the alternate option of AES. 

  • Now here is the strange and funny part.

    • For some reason the Router though it showed the settings saved as AES, it seems it never was actually applied it. The speed was still slow at <20Mbps.

    • Now even after a hard-reset and fresh re-configuration of the Router with AES encryption settings, it did not work.

  • Then I tried disabling the "Security" itself first, on which I got >55Mbps speed and then next I set it to AES.

  • This time it seemed to have applied the settings correctly and the high speed was retained and I have never had the slow-speed  issue again.

  • To confirm this fix I reproduced the steps of going with TKIP and Hard Reset etc and finally back to AES and it has proved to be correct.

Not sure if it's a bug in the Router.

Anyway, for anybody facing similar issue, please do try these steps. I was almost on the verge of returning my router via Amazon but managed to avoid doing it.

Hope this helps somebody with similar router.


FYI here's how I went from ~5-20 Mbps to ~75 Mbps with the exact same router and Comcast Blast! internet:

  1. Install DD-WRT firmware by following this wiki
  2. Use the settings from the last post in this thread

Don't be nervous about installing the WRT firmware. It was as smooth and easy as installing/upgrading firmware made by TP-Link.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .