I had this problem when copying a large (50GB) disk image file (Macrium Reflect) from my Flash Drive to my computer.

"Out of Memory. There is not enough memory to complete this operation." Out of Memory Error Dialog

I had more than double the disk space, had about 12GB of RAM so the error message didn't make much sense to me. But this was largest file I could remember copying so thought the size might have something to do with it.

  • Hi Nathan. I made a few adjustments to your posts to make them even better. If you feel my edits changed your intent, feel free to roll back, or even better simply edit further.
    – user
    Commented Jan 20, 2015 at 12:27
  • First question is what is the file system, NTFS? (if it's fat32, then it won't accept due to file size limitation) - next question is if it's defragmented such that a 50gb file can fit in a single spot. Commented Jan 20, 2015 at 18:59

2 Answers 2


I downloaded Teracopy and tried using that to copy the file; it too failed but gave me a much better file error message: "Open Error: Access is denied"

I check the file Security Permissions (right click Properties --> Security) and indeed the current user did not have Read Access. I add the permissions and it copied fine.

I am guessing because the file was created from a Boot Disk perhaps it didn't know which user to assign the proper NTFS permissions to (although I think it could just leave it open to everyone?)

Also I think Windows 8.1 has a bug when it tries copying a file with wrong file permissions it falls through and displays the wrong error message.

  • I was going to say "Check your filesystem to see if you have FAT32", but I guess I would have failed a lot. I would never think about permissions. Nice catch! Commented Jan 20, 2015 at 10:02
  • 16
    @Ramhound It actually would make sense. If you format a 32GB pen drive with FAT32 and try to copy a file that takes 4GB or more, it will say that you don't have enough space, even if you have 20GB free. Commented Jan 20, 2015 at 12:36
  • 1
    Alright; I see your line of thought; Yes indeed.
    – Ramhound
    Commented Jan 20, 2015 at 12:38
  • 1
    Does Windows still have that annoying property that all file copies have to go through the boot partition? I remember (years ago) that trying to copy a file from a CD-ROM to my D: partition would fail if I didn't have enough space on C: for the temp file.
    – TMN
    Commented Jan 20, 2015 at 17:41
  • 3
    @TMN: Did dinosaurs roam the earth at the time, too?
    – user541686
    Commented Jan 21, 2015 at 9:21

I had this happen today while copying files off a SATA drive connected to a USB3 dock via an adaptor. When I went to check the drive for permissions (as per Nathan's answer) I found that the drives had vanished. I unplugged and replugged the hard drive and it worked fine afterwards.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .