334

I have downloaded and installed the newest virtualbox 4.3.20 for my Windows 7 (64-bit OS), but when I want to install 64-bit Linux, the New->Create Virtual Machine only displays 32-bit option, no 64-bit option. Could anyone give any clues about this issue? Thanks very much in advance!

6
  • 1
    You're sure you installed the amd64 version, correct? – heavyd Jan 20 '15 at 6:05
  • 3
    @Ramhound: Not a duplicate, this is for a 64-bit host. – Andreas Magnusson Jun 4 '18 at 7:12
  • 1
    @AndreasMagnusson My comment was submitted 3.5 years ago. – Ramhound Jun 4 '18 at 12:00
  • 1
    To remedy this on my Win10 machine I needed to go into Control Panel\All Control Panel Items\Programs and Features and Turn Windows Features on or off. From here I needed to UNCHECK the Hyper-V feature that was installed. After rebooting the machine, the 64bit options were displayed – Malcolm Swaine Jun 21 '19 at 9:15
  • 3
    In addition to disabling the Hyper-V feature in the Windows features, I additionally had to go to the Task Manager and manually stop all running "Hyper-V ..." services and the "HV Host Service" from the "Services" tab. After rebooting, the 64bit options were finally displayed. – KiraMichiru Aug 1 '19 at 9:18
320

Take a look: http://www.fixedbyvonnie.com/2014/11/virtualbox-showing-32-bit-guest-versions-64-bit-host-os/

If VirtualBox is only showing 32-bit versions in the Version list make sure:

12
  • 1
    @Tonny On top of this, as far as I remember, if you try to start something like XP Mode when you have VirtualBox VMs running, it will shut down your VirtualBox VMs abruptly without warning. – Bruno Jan 20 '15 at 20:49
  • 1
    @duDE How I can use Hyper-V and Virtualbox at the same time? – user2284570 Feb 13 '15 at 14:29
  • 2
    @ user2284570: Nope, you can't: only one hypervisor can run at a time – Leo Chapiro Feb 14 '15 at 9:01
  • 5
    On win7, after installing VB a restart was required to get the 64 bit options. – T.Coutlakis Oct 16 '15 at 18:48
  • 6
    Any technical reason as to why Hyper-V be disabled? I mean, Virtual box gives the option of 32 bit virtualization even when Hyper-v is enabled; so why not 64 bit? – Mayank Singh Jun 23 '16 at 20:52
10

If you want to emulate 64 bit apps on a 64 bit host, your cpu needs a feature for that. Which duDE says, is an intel-specific copy-paste. The same support exists on AMDs too, there its name is AMD-v - maybe he forgot to mention.

If your cpu doesn't have this support, it won't ever work. If it has, maybe you need to switch this on in your bios.

There are bad BIOSes which can't turn this feature on. Sometimes a BIOS upgrade can in this case help.

0
9

Had the same problem, only seeing 32-bit versions for the host OS's. Started working after updating asus p8z77-v pro bios to latest and enabling virtualization support. Before the bios update, virtubox showed only 32-bit OS's.

4

Windows 10 creators update needed a restart to show the 64 bit OS options in VirtualBox 5.1.22 for my AMD Phenom (tm) II.

Also, the problem might be that you need to TURN OFF the computer after changing the Virtualization options in BIOS, not just restart it.

0
1

On Windows 1903 and Dell laptop, disabling Device Guard using group policy helped to enable 64 bit OS in VirtualBox.

For reference, https://appuals.com/fix-virtualbox-not-showing-64-bit-windows-10/

0

Using the guidance in the answer by @Leo Chapiro I was able to install Debian Buster 10 with Gnome on Windows 10 on a Lenovo ThinkPad. Here's the step-by step way I enabled the 64 bit option in VirtualBox:

  • Restart PC and access BIOS with F1
  • Play with arrow keys and enter to access 'Security > Virtualization' section
  • Check the following options are enabled then F10 to save and exit:

enter image description here

When Windows boots, windows key, type 'Turn windows features on or off', open it and disable HyperV:

enter image description here

Open VirtualBox, it should now allow you to specify a 64bit version.

(I'm using the Debian 10.7.0 amd64 with Gnome iso from the official images page - https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/)

(I followed this guide to install on VirtualBox)

-1

I had same problem with Windows 10, so here is my solution.

Select the Control Panel. Use the Windows 10 Control Panel view, not the legacy view with large/small icons.

Select Programs.

Then under "Turn Windows Features on or off" tick the box Virtual Machine Platform and reboot

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.