Summary: Our WD My Cloud Mirror is slow and unresponsive. As an attempt to resolve this issue I want to remove a backup of my iPhoto library. So far this delete operation has been unsuccessful. I would like to avoid formatting the entire drive. Suggestions are appreciated.

Setup and main problem

We have a WD My Cloud Mirror 6TB with firmware 1.04.05 hooked to my Airport Express 2012 which I access from a 2012 MacBook Pro (OSX 10.10.2, 8GB RAM, SSD drive).

I recently moved the WD drive from my office to my home. Previously I have found the disk a bit slow and awkward to use (I find the software quite weird), but now the problems are bigger than ever. While I unfortunately can't find the source, I read on a forum somewhere that the problem may be that the iPhoto libraries oftentimes have more folders inside them than the WD drives can handle.

Detailed symptoms

  1. Before moving the disk from the office, I tried to back up the iPhoto library as-is to the WD drive. A folder was created, and presumably something is inside it, but I can’t access it in any way. I have tried to delete the folder without any luck. When I try to delete the folder with the WD My Cloud app, it says «Preparing», then «Failed to delete directory».
  2. The WD browsing software («WD My Cloud») is sometimes OK, sometimes slow/unresponsive, sometimes crashing with OS X reporting that «WD MY Cloud quit unexpectedly».
    • When trying to copy folders it sometimes reports the crazy error «Destination folder not found». Uhh… Isn't the idea of copying a folder that said folder should be created, not found?
  3. Browsing the WD drive via the OS X Finder is mostly very slow, sometimes not working at all.
    • Most of the time, nothing happens when clicking the drive icon under Shared in the Finder's left hand column.
    • Sometimes the Finder window itself is responsive, but while in Finder’s column view, nothing happens when I (single-)click a file or folder, indicating that Finder can’t reach the WD drive.
    • At other times the Finder becomes unresponsive, spinning beach ball and all.
    • These symptoms only occur when I try to browse the WD drive.
    • Files seem to be copying OK over to the WD drive (except when the notoriously unstable Airport Express needs to be rebooted).
    • The WD Dashboard and the WD Quick View reports that everything is OK.
  4. The access to the Dashboard has deteriorated.
    • When I did the initial WD drive setup, it created a browser shortcut. This does not work now.
    • The WD Quick View app has another link, http://wdmycloudmirror.local. This does not work.
    • Finally, in the Properties page of the WD Quick View, another address is listed: This opens the Dashboard.
    • Why has the address changed, and why doesn’t http://wdmycloudmirror.local work?
  5. From the time I got the WD drive, the disks are always spinning, even at night when there has been no network activity for hours. Is this normal? I assume this must significantly reduce the life span of the disks? And since there is no power button, I'm assuming WD doesn't want you to power off the device when not in use?

Suggestions? Like I said initially, I hope some problems will solve themselves if I manage to remove the iPhoto backup, but I’m open to other remedies.

  • I don't see how removing a single directory will make the device more responsive. It sounds like you have multiple issues with the device, the one most obvious to me, is I/O problem which indicate a possible hardware failure event. – Ramhound Jan 20 '15 at 16:07
  • Thanks for the feedback, Ramhound. To clarify, I assume there's a ton of files+folders in the iPhoto directory, the WD just won't show or delete them. However I can't confirm until I find a way to investigate the directory. – bjornte Jan 20 '15 at 16:43
  1. Enable SSH access using the web panel
  2. Log in using SSH (The user/pass combination for me was root/welc0me)
  3. Go to the directory (I would guess you can find it in /shares/TheShareYouStoreYouriPhotosOn)
  4. Delete the files using rm -rf iPhoto (this irrecoverably deletes your data, so double-check you are in the right directory).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.