1

I have a Lenovo U410 laptop which have a 1TB hdd and a 32gb ssd. The ssd is used for speeding up the startup time with Intel Rapid Storage Technology. The partition table for the SSD looked something like this: Create new partition on ssd hard (remove hibernate) . One difference is that the ssd consist of only the OEM and the Hibernate partition, where 8GB is hibernate and the rest is OEM, whereas both are formated in a arbitrary file system.

When I booted up in linux, I saw that the ssd had only one partition (the 8gb hibernate part) and the rest was marked "unused". I formated the "unused" part as a ntfs partition so I could use the space. But when I tried to startup windows, it freezes at the windows startup screen (the spining dots stop spinning). Also, it is not possible to start automatic recovery because it forever stays on the 'starting automic recovery' screen.

When I switch to AHCI instead of RAID in the bios it looks like windows starts up alright, but right before the login screens it gives a blue screen. When switched to AHCI it is possible to enter the recovery though.

Does someone know what is going wrong here and know a possible fix? Or a way to find what's going wrong in the background?

3
  • 1
    You will need a 8.1 installion disk since you deleted the recovery environment. – Ramhound Jan 20 '15 at 20:57
  • @Ramhound The problem is that even a installation disk of windows is stuck on the loading screen. But when you switch to AHCI it will boot strangely enough. I've found the problem and have described a solution in the answers. – Bas Jan 21 '15 at 16:32
  • I thought you made no mention of it booting if you switched to AHCI mode. It not booting if Windows was installed with AHCI mode enabled Is perfectly normal. Furthermore if Windows was hibernated, and you deleted the partition that contained the hibernation data, Windows should freak out since it thinks it should be restoring from hibernation. You should always disable hibernation if you want to change the use of a partition dedicated to the hibernation file. – Ramhound Jan 21 '15 at 16:47
0

So today I found a trick to recover the laptop. The problem has to do with the (probably buid into the bios) Intel Rapid Storage technology.

First, make sure to have a backup (this can be done by booting with a linux live usb/cd)

  1. If you cannot get into windows recovery, switch the sata controller in the bios from RAID to AHCI.
  2. In the windows recovery use 'advanced options' and open an terminal.
  3. type DISKPART and use it to delete the partition you created (this can be done with the CLEAN command, but be carefull selecting the right volume!)
  4. Now switch off your pc and enable RAID again in the bios. Now restart.
  5. An Intel Rapid Storage technology configuration menu should popup like this one: https://www.youtube.com/watch?v=nILNNfwfWRs
  6. It will ask to disable or remove the IRST drive, use remove.
  7. Restart your PC and Windows will startup correctly now. It will be slower because the IRST is disabled, but it's better than not starting up at all.

I don't know if there is a easier way to get into the IRST options menu, it would make recovery a lot easier. You can disable IRST in the bios, but this didn't seems to work.

1
  • I had the same problem. I tried this but it didn't work: the Rapid Storage configuration menu didn't appear, and I couldn't see a way to trigger it from the BIOS menus. In the end I gave up and just deleted Windows. Oh well :-) I never used it on my last laptop, anyway. – z0r Jun 8 '15 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.