2

I recently got a 2nd graphics card to add a 3rd monitor but have had problems getting the 3rd to display. The nvidia x server configurations recognizes the 3rd monitor and the 2nd graphics card. When I try to enable the 3rd monitor through the nvidia settings and reboot, it just comes back up with no change. I open the nvidia settings and the 3rd monitor is back to disabled. I have tried editing the xorg.conf file manually to try and add the 3rd screen but so far I have had no luck.

I'm running linux mint with 2 geforce 750ti graphics cards. From my understanding they are not SLI compliant but use a MultiGPU setting which I have on in the conf file.

Here is my configuration file located in: /etc/X11/xorg.conf

I have tried adding a Screen2 as well, but that had no effect. Any help in the right direction would be great!

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@roseapple)  Mon Feb  3 15:07:22 UTC 2014


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2414H"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "DELL U2414H"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor2"
    VendorName     "Unknown"
    ModelName      "HP LA2206"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
    BusID          "PCI:2:0:0"
EndSection

Section "Device"
    Identifier     "Device2"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "On"
    Option         "BaseMosaic" "On"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "On"
    Option         "BaseMosaic" "On"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "Device2"
    Monitor        "Monitor2"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "On"
    Option         "BaseMosaic" "On"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

/var/log/Xorg.0.log

[  7784.174] X Protocol Version 11, Revision 0
[  7784.174] Build Operating System: Linux 3.2.0-70-generic x86_64 Ubuntu
[  7784.174] Current Operating System: Linux pruitt 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64
[  7784.174] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=8197c4cd-c723-4a49-86d5-4ecd04dccbd7 ro quiet splash
[  7784.174] Build Date: 10 December 2014  06:15:52PM
[  7784.174] xorg-server 2:1.15.1-0ubuntu2.6 (For technical support please see http://www.ubuntu.com/support)
[  7784.174] Current version of pixman: 0.30.2
[  7784.174]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  7784.174] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  7784.174] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 20 23:54:46 2015
[  7784.174] (==) Using config file: "/etc/X11/xorg.conf"
[  7784.174] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  7784.174] (==) ServerLayout "Default Layout"
[  7784.174] (**) |-->Screen "Screen0" (0)
[  7784.174] (**) |   |-->Monitor "Monitor0"
[  7784.175] (**) |   |-->Device "Device0"
[  7784.175] (**) |-->Screen "Screen1" (1)
[  7784.175] (**) |   |-->Monitor "Monitor1"
[  7784.175] (**) |   |-->Device "Device1"
[  7784.175] (**) |-->Screen "Screen2" (2)
[  7784.175] (**) |   |-->Monitor "Monitor2"
[  7784.175] (**) |   |-->Device "Device2"
[  7784.175] (**) |-->Input Device "Keyboard0"
[  7784.175] (**) |-->Input Device "Mouse0"
[  7784.175] (**) Option "Xinerama" "0"
[  7784.175] (==) Automatically adding devices
[  7784.175] (==) Automatically enabling devices
[  7784.175] (==) Automatically adding GPU devices
[  7784.175] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  7784.175]    Entry deleted from font path.
[  7784.175] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  7784.175]    Entry deleted from font path.
[  7784.175] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  7784.175]    Entry deleted from font path.
[  7784.175] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  7784.175]    Entry deleted from font path.
[  7784.175] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  7784.175]    Entry deleted from font path.
[  7784.175] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
[  7784.175] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[  7784.175] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  7784.175] (WW) Disabling Keyboard0
[  7784.175] (WW) Disabling Mouse0
[  7784.175] (II) Loader magic: 0x7f579b6e8d40
[  7784.175] (II) Module ABI versions:
[  7784.175]    X.Org ANSI C Emulation: 0.4
[  7784.175]    X.Org Video Driver: 15.0
[  7784.175]    X.Org XInput driver : 20.0
[  7784.175]    X.Org Server Extension : 8.0
[  7784.175] (II) xfree86: Adding drm device (/dev/dri/card0)
[  7784.175] (II) xfree86: Adding drm device (/dev/dri/card1)
[  7784.176] (--) PCI:*(0:1:0:0) 10de:1380:1043:84bb rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[  7784.176] (--) PCI: (0:2:0:0) 10de:1380:1043:84bb rev 162, Mem @ 0xdc000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[  7784.176] Initializing built-in extension Generic Event Extension
[  7784.176] Initializing built-in extension SHAPE
[  7784.177] Initializing built-in extension MIT-SHM
[  7784.177] Initializing built-in extension XInputExtension
[  7784.177] Initializing built-in extension XTEST
[  7784.177] Initializing built-in extension BIG-REQUESTS
[  7784.177] Initializing built-in extension SYNC
[  7784.177] Initializing built-in extension XKEYBOARD
[  7784.177] Initializing built-in extension XC-MISC
[  7784.177] Initializing built-in extension SECURITY
[  7784.177] Initializing built-in extension XINERAMA
[  7784.177] Initializing built-in extension XFIXES
[  7784.177] Initializing built-in extension RENDER
[  7784.177] Initializing built-in extension RANDR
[  7784.177] Initializing built-in extension COMPOSITE
[  7784.177] Initializing built-in extension DAMAGE
[  7784.177] Initializing built-in extension MIT-SCREEN-SAVER
[  7784.177] Initializing built-in extension DOUBLE-BUFFER
[  7784.177] Initializing built-in extension RECORD
[  7784.177] Initializing built-in extension DPMS
[  7784.177] Initializing built-in extension Present
[  7784.177] Initializing built-in extension DRI3
[  7784.177] Initializing built-in extension X-Resource
[  7784.177] Initializing built-in extension XVideo
[  7784.177] Initializing built-in extension XVideo-MotionCompensation
[  7784.177] Initializing built-in extension SELinux
[  7784.177] Initializing built-in extension XFree86-VidModeExtension
[  7784.177] Initializing built-in extension XFree86-DGA
[  7784.177] Initializing built-in extension XFree86-DRI
[  7784.177] Initializing built-in extension DRI2
[  7784.177] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[  7784.177] (II) "glx" will be loaded by default.
[  7784.177] (WW) "xmir" is not to be loaded by default. Skipping.
[  7784.177] (II) LoadModule: "glx"
[  7784.177] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[  7784.185] (II) Module glx: vendor="NVIDIA Corporation"
[  7784.185]    compiled for 4.0.2, module version = 1.0.0
[  7784.186]    Module class: X.Org Server Extension
[  7784.186] (II) NVIDIA GLX Module  331.113  Mon Dec  1 20:24:35 PST 2014
[  7784.186] Loading extension GLX
[  7784.186] (II) LoadModule: "nvidia"
[  7784.186] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[  7784.186] (II) Module nvidia: vendor="NVIDIA Corporation"
[  7784.186]    compiled for 4.0.2, module version = 1.0.0
[  7784.186]    Module class: X.Org Video Driver
[  7784.186] (II) NVIDIA dlloader X Driver  331.113  Mon Dec  1 20:01:51 PST 2014
[  7784.186] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  7784.186] (++) using VT number 7

[  7784.198] (II) Loading sub module "fb"
[  7784.198] (II) LoadModule: "fb"
[  7784.198] (II) Loading /usr/lib/xorg/modules/libfb.so
[  7784.198] (II) Module fb: vendor="X.Org Foundation"
[  7784.198]    compiled for 1.15.1, module version = 1.0.0
[  7784.198]    ABI class: X.Org ANSI C Emulation, version 0.4
[  7784.198] (WW) Unresolved symbol: fbGetGCPrivateKey
[  7784.198] (II) Loading sub module "wfb"
[  7784.198] (II) LoadModule: "wfb"
[  7784.198] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  7784.198] (II) Module wfb: vendor="X.Org Foundation"
[  7784.198]    compiled for 1.15.1, module version = 1.0.0
[  7784.198]    ABI class: X.Org ANSI C Emulation, version 0.4
[  7784.198] (II) Loading sub module "ramdac"
[  7784.198] (II) LoadModule: "ramdac"
[  7784.198] (II) Module "ramdac" already built-in
[  7784.199] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  7784.199] (==) NVIDIA(0): RGB weight 888
[  7784.199] (==) NVIDIA(0): Default visual is TrueColor
[  7784.199] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  7784.199] (**) NVIDIA(0): Option "Stereo" "0"
[  7784.199] (**) NVIDIA(0): Option "nvidiaXineramaInfoOrder" "DFP-1"
[  7784.199] (**) NVIDIA(0): Option "SLI" "Off"
[  7784.199] (**) NVIDIA(0): Option "MultiGPU" "On"
[  7784.199] (**) NVIDIA(0): Option "BaseMosaic" "On"
[  7784.199] (**) NVIDIA(0): Stereo disabled by request
[  7784.199] (**) NVIDIA(0): NVIDIA SLI disabled.
[  7784.199] (**) NVIDIA(0): NVIDIA Multi-GPU auto-select rendering option.
[  7784.199] (**) NVIDIA(0): Option "MetaModes" "HDMI-0: nvidia-auto-select +0+0"
[  7784.199] (**) NVIDIA(0): Enabling 2D acceleration
[  7785.002] (WW) NVIDIA(GPU-0): Both the "MultiGPU" and "SLI" X configuration options were
[  7785.002] (WW) NVIDIA(GPU-0):     specified.  The "SLI" option will take precedence.  Please
[  7785.002] (WW) NVIDIA(GPU-0):     see Chapter 29: Configuring SLI and Multi-GPU
[  7785.002] (WW) NVIDIA(GPU-0):     FrameRendering for more information.
[  7785.002] (EE) NVIDIA(GPU-0): Failed to find a valid Base Mosaic configuration.
[  7785.002] (EE) NVIDIA(GPU-0): Invalid Base Mosaic configuration 1 of 1:
[  7785.002] (EE) NVIDIA(GPU-0): GPUs:
[  7785.002] (EE) NVIDIA(GPU-0):     1) NVIDIA GPU at PCI:1:0:0
[  7785.002] (EE) NVIDIA(GPU-0):     2) NVIDIA GPU at PCI:2:0:0
[  7785.002] (EE) NVIDIA(GPU-0): Errors:
[  7785.002] (EE) NVIDIA(GPU-0):     - The video link was not detected
[  7785.002] (EE) NVIDIA(GPU-0):     - Unsupported GPU
[  7785.002] (EE) NVIDIA(GPU-0):     - Chipset not approved for SLI
[  7785.002] (WW) NVIDIA(GPU-0): Failed to find a valid Base Mosaic configuration for the
[  7785.002] (WW) NVIDIA(GPU-0):     NVIDIA graphics device PCI:1:0:0. Please see Chapter 29:
[  7785.002] (WW) NVIDIA(GPU-0):     Configuring SLI and Multi-GPU FrameRendering in the README
[  7785.002] (WW) NVIDIA(GPU-0):     for troubleshooting suggestions.
2

Multiple monitors is indeed something that takes a bit of finesse. It took me a while to make X play nice. At first glance it appears that "Screen 1" hasn't been added to the "ServerLayout"

Take a look at my xorg.conf file I use for 4 monitors. It physically looks something like this:

Screen2 - Screen 1 - Screen 3
             |
          Screen 0

Here is my xorg.conf file

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 960 1024
    Screen      1  "Screen1" 1280 0
    Screen      2  "Screen2" LeftOf "Screen1"
    Screen      3  "Screen3" RightOf "Screen1"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
    EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HannStar Display Corp HZ251H"
    HorizSync       30.0 - 85.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Dell DEL 1708FPBLK"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor2"
    VendorName     "Unknown"
    ModelName      "Dell DEL 1708FPBLK"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor3"
    VendorName     "Unknown"
    ModelName      "Dell DEL 1708FPBLK"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Device"
    Identifier     "Device2"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
    BusID          "PCI:3:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen2"
    Device         "Device2"
    Monitor        "Monitor2"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen3"
    Device         "Device3"
    Monitor        "Monitor3"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"`
    Option         "Composite" "Disable"
EndSection

Hope that helps a bit

  • I see what your saying about the layout. I tried to add them to the ServerLayout and i also added the extra monitor, screen, and device but still nothing has changed. Reloaded and only the 2 monitors plugged into the first GPU are working... I changed the file above so you could see what I added. I've been over it a ton, and it looks like it should be right, but im still stuck with two monitors... – Chris Jan 21 '15 at 5:57
  • @Chris Could you add the /var/log/Xorg.0.log? It may help see what is going on. – Chris Lawrence Jan 21 '15 at 11:55
  • Ok I posted the log, but not positive of any conflicts. It does say "Unsupported GPU" but both are the same GPUs and the first on in PCI:1:0:0 works fine – Chris Jan 21 '15 at 16:06
  • @Chris - Hmmm. That is puzzling. Going backwards a bit, when you use nvidia-settings, how does the generated file compare with what you are trying to use at the moment. Also, have you tried to use Xinerama instead of base mosaic? Other thoughts - It indicates that the cards aren't able to use SLI, have you checked the global xorg.conf file for conflicting settings? – Chris Lawrence Jan 22 '15 at 1:14
  • Ok so this is very interesting. I enabled Xinerama and disabled base mosaic and on reboot all 3 screens are glowing dark blue and I have a mouse that I can move around all 3 screens. But there is no interface. This happened a few days ago when I was playing around with xinerama but couldn't quite get past this state either. – Chris Jan 22 '15 at 1:45
1

Stupid me. I read the specs online for this graphics card and it can handle 4 displays on its own. Just had to get a converter for DVI and it works like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.