4

On Windows 8, I'm using a wireless hosted network with ICS. I have one interface connected to internet, and my WiFi interface as a wireless access point. The interface that is connected to internet is a USB modem.

This is what I did, I ran these commands:

netsh wlan set hostednetwork ssid=* key=*
netsh start hostednetwork

Then I configured the ICS on the interface connected to internet and linked it up with the new virtual WiFi access point interface.

Then I connected my Android phone to the WiFi access point and tried to access the internet.

An error occurred on the browser, telling me that the DNS did not resolve.

So I modified (static config) the WiFi configuration on my Android phone to use Google DNS 8.8.8.8 and 8.8.4.4 and everything worked.

The WiFi interface is on 192.168.137.1, so my Android phone connected in that particular range, and set the gateway & DNS to the same IP.

In all the guides I've read on the internet, no site mentioned this problem. I don't understand why the DNS information is not propagating from the USB modem -> WiFi Access Point -> Android phone WiFi?

Even if I set the DNS servers on the WiFi access point interface statically to Google DNS, it still doesn't work.

The internet connection only works properly if I set the DNS servers on my Android phone's WiFi configuration. If I don't, I can only use direct IPs.

Any ideas?

1

I had the same issue, frustrating to get no connection when connecting to the windows hostednetwork because of no DNS being sent to the connected devices.

I found the solution here: https://4sysops.com/archives/how-to-share-wi-fi-in-windows-8-with-internet-connection-sharing-ics/ I read it before but didn't get it until the second time around, the steps that go like this are important:

  • Start the hostednetwork as you are doing.
  • Be connected to the network with the internet access you want to share with others.
  • Go to Control Panel\Network and Internet\Network Connections and you will see your internet connection and your hostednetwork as something like "Local Area Connection* XX". Even though it's a wifi connection you are hosting, it will still be called a "LAN" connection.
  • Now open the Properties of your source internet connection and go to Sharing tab and select to share the connection with the "LAN * XX" connection.

Now in summary, when you connect to the hotspot after sharing the source connection with your hostednetwork connection, the DNS will start being sent to the devices that are connected via DHCP automatically.

Addendum A: Make sure that there is no DNS setting manually set on the "Local Area Connection*3" for example, it should just be empty: enter image description here

  • Also, for me, sometimes I have to enable the Ethernet connection (just enable not using it actually), just to get the other hostednetwork to show up as an option for sharing. – David d C e Freitas Aug 13 '16 at 4:58
  • Blanking out the DNS addresses will just make the radio button go back to using Automatic DNS – WhiskerBiscuit Sep 2 '16 at 11:33
  • Oh, I also have to redo this action every now and then because the DNS gets lost after some time of switching it on and off I guess. – David d C e Freitas Nov 11 '16 at 15:20
0

To create a Network Bridge at least two LAN or High Speed Internet connections must be selected that are not being used by Internet connection sharing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.