1

I have a program that requires .NET 3.5. When I run it on my Windows 8.1, I get a pop-up saying:

An app on your PC needs the following Windows feature:
.NET Framework 3.5 (includes .NET 2.0 and 3.0)
[Download and install the feature]

The "Download" link starts installation, which fails with Error code: 0x800F0906, and a link to generic-style advice like "check your Internet connection". I also tried:

  • Installing from Windows Features dialog, but got the same error.
  • Downloading and running dotnetfx35.exe - got redirected to the above and failed with the same error.

Following Corrupted Flash Update prevents Windows Update - DISM fails 0x800f0906, I tried running sfc /scannow and dism /online /cleanup-image /scanhealth, but neither fixed the issue or produced intelligible logs.

So, how do I install .NET 3.5 on Windows 8.1?

2

Following output from sfc, I turned to read c:\Windows\Logs\CBS\CBS.log. At the time of failure, I saw the following lines:

Failed to find package: Package_78_for_KB2966828~31bf3856ad364e35~amd64~~6.3.1.4 from the index with mapping index packages recently rebuilt,  [HRESULT = 0x800f090d - CBS_E_MISSING_PACKAGE_MAPPING_INDEX]
Failed to get WU category/updateID for package: Package_78_for_KB2966828~31bf3856ad364e35~amd64~~6.3.1.4 [HRESULT = 0x800f090d - CBS_E_MISSING_PACKAGE_MAPPING_INDEX]
Failed to get the category and update ID for package: Package_78_for_KB2966828~31bf3856ad364e35~amd64~~6.3.1.4, component: amd64_microsoft-windows-wpfcorecomp.resources_31bf3856ad364e35_6.3.9600.20708_en-us_a3b67b207d2057ab, file: PresentationHostDLL.dll.mui [HRESULT = 0x800f090d - CBS_E_MISSING_PACKAGE_MAPPING_INDEX]
Exec: Missing files are found during staging attempt but failed to download content from WU. [HRESULT = 0x800f090d - CBS_E_MISSING_PACKAGE_MAPPING_INDEX]

On a hunch, I uninstalled KB2966828 mentioned in the log, and voilà - installation works! I hope Windows Update will install it again if it's really important...

  • The reason the DISM tool didn't fix the problem is because the actual component appears to have been missing. Really the only thing the command you ran does is verifies the components in the WinSxS directory are not corrupt. Likewise the sfc tool compares those components in the WinSxS directory to your system components. It also appears it attempted to download the missing data but wasn't able to. This can be solved by using the DISM tool against local WinSxS source ( i.e. an installation disk ) this way you don't have to worry about not being able to download the content. – Ramhound Jan 22 '15 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.