0

HP-Laptop has W7 Home Premium SP1 (64) running and was set up newly from scratch. No programs installed, except all the crap, that HP delivers as preinstall. Until now, no Antivirus is installed. User has Admin privileges.

All Updates worked fine - execpt a .NET client component. Windows Update tried to install KB982670 (.Net 4 Client Profile for W7 x64 based Systems). This did not work out, the update never got to an end - after several hours i had to do a forced shut down.

Then i downloaded the installer manually and tried to install by hand, answering the UAC window with yes ... then the install seemed to start, the small circle was rotating for 2 or 3 seconds and thats it. Nothing happened, nothing was installed, no error message came up. Then i tried to install manually the full .NET framework 4, 4.51 (KB2858728) and 4.52 (KB2901907). Same problem, after a few seconds the rotating indicator changes back to normal cursor mode and nothing has happened.

There are no "leftovers" or any other trace of .NET 4.XX components on the machine. I checked that manually and also with the verification tool (the older frameworks are all there and are ok).

I also tried a clean boot and then a manual install again - but got the same result. Whatever version or component of .NET 4.XX i want to install - simply nothing happens.

I had to deactivate all the automatic updates connected to .NET 4.XX in order to not get stucked while shutting down the computer. This is the only issue i have with that computer. But i'm afraid, that every next .NET 4 security-Update will send my computer hanging again, until i have deactivated that particular update.

Any idea or suggestion would be highly appreciated.

  • Here is my suggestion. Run the .NET Framework Cleanup Tool remove everything. You can then install .NET Framework 4.5.2 and see if you have any luck. Just to be on the safe side run this tool before you do that. – Ramhound Jan 22 '15 at 13:29
  • the repair tool will not start either :-( only the verification tool works – Richard Jan 22 '15 at 13:54
  • If the repair tool does not work, use the cleanup tool, remove everything. Every problem I have ever had with .NET Framework has been solved with that repair tool. – Ramhound Jan 22 '15 at 14:00
  • The cleanup-tool worked... i ran it on every version of .NET 4.XX - but that did not make one of the installers work afterwards. And the Cleanup-tools-Log also said, that there had not been any Versions of 4.XX that could have been removed. – Richard Jan 22 '15 at 14:02
  • I assume you have restarted your computer? The next step is to install the available updates, that become available since you have no version of .NET Framework installed, one at a time. – Ramhound Jan 22 '15 at 14:04
0

You can try the Method 2 from this article:

Disable .Net framework from Windows feature following the steps below:

a. Click the Start button, click Control Panel, click Programs, and then click Turn Windows features on or off. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

b. To turn off .Net framework, click on Media feature. And .Net framework and click on OK.

c. Restart the computer to apply the changes.

Note: follow the above steps to turn on or enable .Net framework and check if the issue occurs.

For more information, refer to this link Turn Windows features on or off:

http://windows.microsoft.com/en-US/windows7/Turn-Windows-features-on-or-off

  • Thanks for the suggestion - but that did not work out. – Richard Jan 22 '15 at 13:06
  • Thanks for the suggestion - but that did not work out. DotNet is not a general topic that i can find under "Media features". Instead there is a distinct entry for "Microsoft .NET framework 3.5.1" directly below "Media features" - but as i understand it, this applies only to 3.51. For 4.XX i cannot find anything. Like i said - there are no traces of 4.XX on the machine. So i have no entry to deactivate what is not there ... – Richard Jan 22 '15 at 13:14
  • Have you tried this tool: support.microsoft.com/kb/2698555 ? – duDE Jan 22 '15 at 13:19
  • Yes - but that tool has the same problem on that laptop, as the installers do have ... it looks like it would start, UAC question has to be answered, then curser indicates "working" for about 3 or 4 seconds, and then ... nada, no error, no message – Richard Jan 22 '15 at 14:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.