0

I have a laptop with the graphic card GTX760m and the integrated card HD4600.

The things is that when I play games, it always selects the integrated card instead of the nvidia card.

I change the settings in the Nvidia control panel to make the game run on the Nvidia card, but everytime I open the game, it automatically switch the settings back to the integrated card.

For some games, I can right click on the game icon and select run this with the nvidia card, then the game will use the nvidia card even if the settings are still the integrated card.

But for some other games, right click and select the nviddia card doesn't work, it still uses the integrated card.

I tried this with the charger on, battery on. And with charger on, battery off. Neither of it works. So doesn't seem to be the battery problem.

Any helps? Thanks.

  • Have you checked the Global Settings tab ? – TechLife Jan 22 '15 at 18:32
  • @TechLife . Even when I change the global setting to High performance NVIDIA rocessor, once I open the game, it will automatically go back to Integrated graphic card. – Orion Lullaby Jan 22 '15 at 22:07
  • What is the name of that game ? – TechLife Jan 22 '15 at 22:08
  • @TechLife It's not only one game, it's every game that's on my laptop. Like NBA 2K 15. Earlier today. I couldn't even force it to use High performance NVIDIA rocessor by right click and select to run the game with High performance NVIDIA processor. But now it works, but still, if I directly double click, it will use integrated card no matter what the settings are. – Orion Lullaby Jan 22 '15 at 22:37
  • have you tried installing the latest driver? or at least uninstall and reinstall it? – TechLife Jan 22 '15 at 22:38
3

From this post:

From NVIDIA Control Panel
3D Settings->Manage 3D Settings
Tab "Global setttings"
Preferred Graphics Processor
Select : High performance NVIDIA rocessor

Alternatively, you could check if you can set the Nvidia card as the preferred graphics card for the game you're using. You could try what is described here:

  1. Go to the NVIDIA Control Panel by right clicking on your desk top and clicking on "NVIDIA Control Panel".
  2. In the default screen that pops up (it should be "manage 3D settings", and the "Program Settings" tab should be automatically selected), under "1. Select a program to customize:" hit the "Add" button.
  3. From here, navigate to the folder where your steam games are located. For me, it is C:\Program Files (x86)\Steam\steamapps\common.
  4. Select the folder for the game you want to use your NVIDIA card for, and find the .exe for that game (it's usually right in the main game folder). Select it and hit open.
  5. Then, under "2. Select the preferred graphics processor for this program:" open the drop-down menu and select "High-performance NVIDIA processor".
  6. Finally, hit apply in the far bottom right corner, and you should be good to go!

According to the author of what I've quoted, this should work for any .exe.

  • I tried global settings, set to High performance NVIDIA rocessor. But it still doesn't work. The problem is once I open the game, the settings will automatically change from High performance NVIDIA rocessor to Integrate. – Orion Lullaby Jan 22 '15 at 22:06
  • I've edited my answer to add another method to set the definition for each application. If that still doesn't work, you can try to check if it is possible to disable the switchable graphics in the BIOS of your computer and use only the Nvidia card. Please bear in mind that this might lead to an increase of the internal temperature of the computer. – m-oliv Jan 22 '15 at 23:27
  • I've also tried that, but it doesn't work – Orion Lullaby Jan 23 '15 at 3:47
  • Your BIOS doesn't have any option to set the Nvidia card as the default? If it is the only graphics card used, maybe it'd solve the issue. There is, as I mentioned before, the possibility that the computer gets hotter due to this change. – m-oliv Jan 23 '15 at 18:16
0

You need to also make sure that the .exe you are configuring to run on the nvidia is the game's real executable file, some games use a launcher, so once the game starts it opens another process with the real executable and that one needs to also might be incorrect configured to run on the nvidia card.

It has happen to me in the past right now I am playing the dmc hd collection and the windows' menu listed the launcher as the game main binary dmcLauncher.exe if I configure that one to use the nvidia card once I start the game (dmc3) it lags like hell, but it I go through the steam folder I can see the real executables for each game

dmc1.exe
dmc2.exe
dmc3.exe

I configure those and done game runs smoothly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.