I've installed OpenWRT Snapshot R43972 on a router that is not officially supported (a Swisscom Centro Grande resp. Pirelli / ADB according to the descriptions here and here. However, the PCB layout is slightly different than in the photos there.

So far it seems to work, except for the wireless. I have tried most settings in luci, and severall manual changes to /etc/config/wireless, but I could neither set it up as an AP nor receive any signals. Hence, I suspect that the problem is somewhere deeper, and I don't see a way to localize the problem further.

It starts nicely with

$> dmesg | grep b43
Sun Jan 18 23:13:32 2015 kern.info kernel: [   16.196000] b43-phy0: Broadcom 4322 WLAN found (core revision 16)
Sun Jan 18 23:13:32 2015 kern.info kernel: [   16.236000] b43-phy0: Found PHY: Analog 8, Type 4 (N), Revision 4
Sun Jan 18 23:13:32 2015 kern.info kernel: [   16.240000] b43-phy0: Found Radio: Manuf 0x17F, ID 0x2056, Revision 3, Version 0

But then:

$> logread | grep radio
Sun Jan 18 23:13:48 2015 daemon.notice netifd: radio0 (692): Configuration file: /var/run/hostapd-phy0.conf
Sun Jan 18 23:13:48 2015 daemon.notice netifd: radio0 (692): nl80211 driver initialization failed.
Sun Jan 18 23:13:48 2015 daemon.notice netifd: radio0 (692): hostapd_free_hapd_data: Interface wlan0-1 wasn't started
Sun Jan 18 23:13:48 2015 daemon.notice netifd: radio0 (692): hostapd_free_hapd_data: Interface wlan0 wasn't started
Sun Jan 18 23:13:48 2015 daemon.notice netifd: radio0 (692): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Sun Jan 18 23:13:49 2015 daemon.notice netifd: radio0 (692): Command failed: Invalid argument
Sun Jan 18 23:13:49 2015 daemon.notice netifd: radio0 (692): Device setup failed: HOSTAPD_START_FAILED

I would appreciate any hint on how to proceede!

Disclaimer: I haven't gotten a reply to this question on the OpenWRT forums after serveral days, so I'm crossposting here.

up vote 2 down vote accepted

I was having the same problem on my device (Tenda W300D) with r44093. I found that the Mac Address had been pre-configured wrong so I changed:

/sys/class/ieee80211/phy0/macaddress

from

00:00:00:00:00:00

To the Mac on the bottom of my router:

c8:3a:52:75:51:08 

then

/var/run/hostapd-phy0.conf

to

bssid=c8:3a:52:75:51:08

Finaly

/etc/config/wireless

add

option macaddr C6:3A:35:27:51:08

Now the wifi should have the correct Mac set just reset your network:

/etc/init.d/network restart
wifi up
  • Amazing, I would not have thought of that! – mbschenkel Jan 29 '15 at 22:25

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.