I am using mac OSX and have installed python 2.7.9 via this article,

from /usr/bin if I run the command ls -l /usr/bin/python* in a bash terminal, I get

lrwxr-xr-x  1 root  wheel  67 Jan 24 02:12 /usr/bin/python -> /System/Library/Frameworks/Python.framework/Versions/2.7/bin/python
lrwxr-xr-x  1 root  wheel  74 Jan 24 02:12 /usr/bin/python-config -> /System/Library/Frameworks/Python.framework/Versions/2.7/bin/python-config
lrwxr-xr-x  1 root  wheel  75 Oct 19 16:39 /usr/bin/python2.6 -> ../../System/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6
lrwxr-xr-x  1 root  wheel  82 Oct 19 16:39 /usr/bin/python2.6-config -> ../../System/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6-config
lrwxr-xr-x  1 root  wheel  75 Oct 19 16:39 /usr/bin/python2.7 -> ../../System/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7
lrwxr-xr-x  1 root  wheel  82 Oct 19 16:39 /usr/bin/python2.7-config -> ../../System/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7-config
lrwxr-xr-x  1 root  wheel  68 Jan 24 02:12 /usr/bin/pythonw -> /System/Library/Frameworks/Python.framework/Versions/2.7/bin/pythonw
lrwxr-xr-x  1 root  wheel  76 Oct 19 16:39 /usr/bin/pythonw2.6 -> ../../System/Library/Frameworks/Python.framework/Versions/2.6/bin/pythonw2.6
lrwxr-xr-x  1 root  wheel  76 Oct 19 16:39 /usr/bin/pythonw2.7 -> ../../System/Library/Frameworks/Python.framework/Versions/2.7/bin/pythonw2.7

If I run ls -l | grep easy_install, I get

-rwxr-xr-x   2 root   wheel       925 Sep  9 19:31 easy_install
-rwxr-xr-x   1 root   wheel       454 Sep  9 19:31 easy_install-2.6
-rwxr-xr-x   1 root   wheel       461 Sep  9 19:31 easy_install-2.7

And when I look at the shebangs for each of these 3 files they are respectively

#!/usr/bin/python
#!/System/Library/Frameworks/Python.framework/Versions/2.6/Resources/Python.app/Contents/MacOS/Python
#!/System/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python

I have tried chmod-ing the write permissions so I can go in there and change the paths myself, but am still told by an alert in my IDE that I don't have write permissions when I do so. I also feel like I could be messing with files that might harm my system if I don't have them configured the right way. Could somebody tell me how to set up easy install so that it will work properly when I run a command like sudo easy_install six? Right now when I run this it is telling me

unable to execute /System/Library/Frameworks/Python.framework/Versions/2.7/bin/easy_install: No such file or directory

I have cd'd into that directory and changed the easy_install2.7 file that lives there to simply easy_install, but I still get the same error. I have also tried copying the easy_install file from /usr/bin to that location with no luck:

python version 2.7.9 can't run /System/Library/Frameworks/Python.framework/Versions/2.7/bin/easy_install.  Try the alternative(s):

/System/Library/Frameworks/Python.framework/Versions/2.7/bin/easy_install (uses python 2.7)
/System/Library/Frameworks/Python.framework/Versions/2.7/bin/easy_install-2.7 (uses python 2.7)

I have since returned all of the files to their original names and removed the /usr/bin version of easy_install from the 2.7 directory. Could somebody please help me out here?

Other important information:

  1. I am trying to set up a local Cassandra cluster using ccm which is why I need to install these Python libraries

  2. I installed Cassandra via this link. In this article they have me install the latest python via homebrew, so my problem could be due to having alternative installations of Python on my system. I know this is a nono but decided to do it because I didn't feel comfortable copying my homebrew files into my System folder.

Neither the Homebrew or python.org python installs change anything in the system directories.

They both put python into /usr/local/bin and this is what should be on your path before /usr/bin to allow you tp run python from the command line.

easy_install should be installed using this python and will put easy_install in /usr/local.bin wot the correct header.

  • I just went to /usr/bin and found easy_install, easy_install-2.6, and easy_install-2.7. I changed the names so that 2.7 is now just easy_install and it runs, but gives me a distribution not found error on the library. Is this the right approach?? – kurofune Jan 25 '15 at 18:03
  • No - never touch anything in system directories - see /usr/local./bin and install easy_install from that python – Mark Jan 25 '15 at 18:14
  • Ok, I'll change the names back now. I Is there a short list for which directories are "system" land which are for changing? – kurofune Jan 25 '15 at 18:18
  • I should also mention that the first thing the Python.org article told me to do was execute this: 'sudo rm -R /System/Library/Frameworks/Python.framework/Versions/2.7', which I did. I did however follow all of the steps after that too. – kurofune Jan 25 '15 at 18:20
  • That article is not from python.org and so is not the official doc - and deleting that path is wrong as it breaks any Apple an possibly third party code that uses python - that delete does explain your error message as you have broken Apple's python which all the files min /usr/bin run – Mark Jan 25 '15 at 18:27

I have the same issue:

    Dhruv’s MacBook Pro:~ dhruv$ sudo easy_install pip
Password:
sudo: unable to execute /System/Library/Frameworks/Python.framework/Versions/2.7/bin/easy_install: No such file or directory

And I followed the same tutorial mentioned. How do I use a python from a particular directory, if that is what you are saying?

  • I actually ended up reinstalling Yosemite so that the old version of Python with proper symlinks was restored and then installed 2.7 in usr/local/bin, isolated from my system files. If you haven't deleted anything yet, then I would suggest just making sure you have the right files and that your symlinks are pointing to the right places. – kurofune Feb 20 '15 at 23:54
  • This is an overview of symlinks and how to make and destroy them: kb.iu.edu/d/abbe – kurofune Feb 20 '15 at 23:57

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.