5

How to set UK language in MS word 2007 for always as default language?

4 Answers 4

4
  1. Go to Start > All Programs > Microsoft Office > Microsoft Office Tools > Microsoft Office 2007 Language Settings.

  2. When you have done that, you will see a window as shown below:

alt text

Ensure that the enabled editing languages you need are in the Enabled Editing Languages box on the right hand side and that the default the Primary Editing Language is set in the box at the bottom of the window as shown above. This will be the default dictionary.

Edit:

Try this:

  1. Right click on a misspelled word in your document
  2. Language –> Set Language –> select preferred language (e.g. English (UK)) –> Default… –> YES –> OK.
5
  • but if i remove english US from here . it comes automatically again if we check this setting again Dec 23, 2009 at 14:32
  • did you remove English (U.S.) from the "Enabled editing languages"?
    – Molly7244
    Dec 23, 2009 at 14:49
  • @molly- yes i removed Dec 23, 2009 at 14:54
  • I don't think it's possible to remove English (U.S.). Just add English (U.K.) and make sure it's selected as Primary.
    – Richard
    Mar 30, 2010 at 23:17
  • It's still not working even if i set UK for the document, pasting a new paragraph way set a US language language there. Apr 7, 2010 at 3:28
2

Click on the language in the status bar.

The language selection dialog appears.

Select "English (United Kingdom)" and then click on the "Default..." button (bottom left on the form).

I think that should do it. If not select "English (United Kingdom)" then "OK" then repeat and select "Default..." the second time.

3
  • no language button on my status bar Dec 23, 2009 at 14:33
  • 1
    @Jitendra - It should appear in words on left of the status bar. I don't think I've done anything special to my install.
    – ChrisF
    Dec 23, 2009 at 14:57
  • Right click the statusbar then tick language
    – Piecevcake
    May 26, 2021 at 20:38
0

I don't see the language in the status bar. The language tool is also found under Review | Set Language. Choose the default language then the "Default..." button.

1
  • The status bar appears at the bottom of the Word 2007 window, and the third entry from the left on such status bar allows you to set the Language for the current document. You have to click once inside the document for this entry to appear. Regards. Jan 9, 2015 at 15:36
0

Don't Forget to check your Language and Regional Settings in the Control panel. Office looks here first to grab default settings. If the keyboard language not set right for keyboard it will revert back..even if you set everything correctly in word. The Rest of the control panels can be found under the office button in word going to word options and set your defaults from there. This is how I was able to correct for Canadian English to Default..Hope it works for you!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.