0

I have been using Windows 8.1 on my laptop(lenovo) for a while now and decided to try and install Ubuntu so I can dual-boot Windows and Ubuntu. So today I installed Ubuntu 14 on a separate partition now when I start my laptop, GRUB lets me choose between:

  1. Ubuntu
  2. Ubuntu config (or something similar)
  3. System config (or something similar, basically takes me to the BIOS settings)
  4. Windows Boot Loader

When I choose 1. (Ubuntu) it starts Ubuntu without any problems and as far as I can see, all the files on C: and D: are the way they were before and Ubuntu is using the 3rd partition like it should. But when I choose 4. (Windows Boot Loader) I get an error message:

/EndEntire

file path: /ACPI(a0341d0,0)/PCI(2,1f)/Sata(0,0,0)/HD(2,96800,32000,563b8c100b976748,2,2)/File(\EFI\Microsoft\Boot)/File(bootmgfw.efi)/EndEntire

error: cannot load image.

But if I choose 3. (System config) and change the boot order so that Windows Boot Loader is first, It boots into Window without any problems but it does not let me choose between Windows or Ubuntu. Is there a way to make the GRUB be able to start my Windows or a way to start Ubuntu from the Windows Boot Loader?

Any help will be much appreciated!

1

I had this EXACT issue just a couple of weeks back! Check out my question on the LinuxQuestions forum; it should solve your problem.

In case the link becomes broken in the future, here is the copied and pasted solution from that post:

"Update: Problem solved. I'm able to boot both Lubuntu and Windows from GRUB. The issue was that I thought Secure Boot was disabled, when it really wasn't!

For anyone who has a Lenovo G500 laptop like me, take a look at this post on the Lenovo forums. There are TWO options for disabling Secure Boot in this brand of laptop, and unless you select "Disabled" for both options, Secure Boot will not be turned off. This is how it would look:

Secure Boot Disabled (this is fine)

Secure Boot Status Enabled (you cannot change this option; it's grayed out. Until you change it, Secure Boot won't be disabled)

To completely disable Secure Boot on your Lenovo G500 (or other laptop if it has a similar configuration), you must click on the option "Reset to setup mode" underneath the "Secure Boot Status" option. Hit "Yes" on the confirmation popup. Now, the "Secure Boot Status" will show up as "Custom". That means, Secure Boot is completely turned off (provided the above "Secure Boot" option displays Disabled). If you ever want to turn Secure Boot on again, click on "Restore factory keys".

Hopefully this helps someone who has the same problem I did. Chances are, your laptop has a confusing Secure Boot configuration and you just didn't turn it off properly."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.