32

After a few minutes, the screen turns black and a screensaver will come out if I move the mouse, like on the screenshot below. How to turn all these off? The OS is Centos 7.

screen

3 Answers 3

38

More detail:

  • Click on the power icon in the upper left.
  • Click on settings(wrench/screwdriver picture/icon).
  • Click on the power icon.

Under power saving is the selection for blank screen, mine was set to a default of 5 min. I changed it to never.

1
  • This answer should get the credit. Thank you. Dec 11, 2018 at 19:18
4

In your terminal write these commands:

xset s off
xset s noblank

EDIT1:

Try with this script:

#!/bin/sh
export DISPLAY=:0.0
xset s off
xset s noblank
xset -dpms
1
3

In centos 7, click on your username in the upper right corner. Then click 'Power' and change the time to what you want. There is an option for 'Never' so that your screen will quit going black.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.