So first of all I do not want to use VMWare with Vagrant. I want to use VirtualBox. I am running on OSX 10.9 by the way.

A few days ago I installed Vagrant. I followed the instructions to set up VMWare Fusion and added the provider.


I then realised you had to pay for another license to use VMWare Fusion with Vagrant. I opted out of that. So I downloaded VirtualBox and installed it. I removed VMWare Fusion completely. Removed Vagrant following the instructions on the page, and also ran Onyx to clean up anything. I ran a 'find' command and there was no Vagrant files on the system.

I reinstalled Vagrant. Reinstalled VirtualBox. When I ran:

vagrant box add laravel/homestead

I got the following error:

A valid license is required to run the Vagrant VMware
provider. Please visit http://www.vagrantup.com to purchase
a license. Once you purchase a license, you can install it
using `vagrant plugin license`.
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.


Any Vagrant command I run outputs this error.

I've been struggling to get this working for days. I have no VMWare files on my system, and I removed all of the Vagrant files. So why is it still looking for VMWare?


I fixed it by removing the VMWare Fusion plugin:

vagrant plugin uninstall vagrant-vmware-fusion

I am not sure why the plugin remained after I completely removed Vagrant, but it works.

  • 1
    In addition the basic usage help mentions: vagrant up --provider=virtualbox and how it chooses a default provider. – Brian Jan 25 '15 at 0:27

I found that the --provider=virtualbox option did not work as long as I had the vagrant-vmware-workstation plugin installed. Uninstalling the plugin did the trick.


I had to do both uninstalls:

vagrant plugin uninstall vagrant-vmware-fusion vagrant plugin uninstall vagrant-vmware-desktop

Re-installing vagrant didn't work which make believe that at least on MacOS the uninstaller script is flawed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.