1

Some days ago I attached my usb external hard drive, and windows started to say like that:

"Disk/drive is not formatted. Do you want to format it now?"

So I downloaded testdisk and I tried to repair partition. I did it with no problem, but windows can't read it anymore.

Testdisk, using Advanced -> List, can read all files with no problem and even copy them. The problem is: files are more then 900 GB, so I don't have enough space to copy them in another place, format and finally recover... So... why testdisk can read them and windows no? Is there any way to recover partition?

Here's my testdisk log: http://pastie.org/9858876

Some more infos: my drive is ntfs, intel type partition table, 1 TB.

1

If go through "Analyse" and run a "Quick Search" in Testdisk I assume it shows your partition structure? If so, you can then select the option in Testdisk to "Write" which will save the partition structure to the disk. Reboot the machine and you should see the drive as normal.

For more info you can follow this step-by-step tutorial from Testdisk.

  • 1
    I already tried the standard way... Also after pressing "write", after "quick search" and rebooting, my partition is in the same state... Any ideas? – ProGM Jan 28 '15 at 19:10
  • Were the partitions green and have a primary? If so what about the state of the boot sector, has that been checked? – user409554 Jan 28 '15 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.