0

I've been having this weird problem with my Apple TV when streaming audio. It will randomly stop working. Usually when that happens, it will duplicate itself in the device list on all devices we have here. It goes from "Apple TV" to "Apple TV" AND "Apple TV (2)". I can't figure out what happens that makes it go back to only one device.

I noticed that often it will stop working shortly after the iPhone or iPad goes into sleep mode, but sometimes I still have it on and the same error happens.

Haven't found much info online about this. Tried a different router and am hitting the same problems. Do you have any idea what could it be?

Thanks.

Here's the device list:

Apple TV A1427 - AppleTV3,1 - iOS 7.0.2 (Ethernet, HDMI to TV, Optical from TV to Amp) iPhone 5S - iOS 8.1 iPhone 5S - iOS 8.1 (Jailbroken) iPad Air - iOS 8.1

2
  • Is the IP address changing? If so try setting a DHCP reservation or whatever your router calls that function. I've had this problem, with my linksys EA6900 router all of my iDevices were getting new IPs constantly. After forcing the router to always use the same for the device several problems cleared up. I've since switched to a netgear router and set reservations for all devices to start with (never tested without).
    – Tyson
    Jan 26 '15 at 0:54
  • No, IP address is the same. I have an ASUS RT-AC68U router, for what it's worth.
    – awfulcode
    Jan 26 '15 at 17:13
0

Did these problems coincide with the release of OS X 10.10? Yosemite has some known problems with Bonjour and discovery, due to replacing their entire DNS codebase with a new tool called discoveryd.

http://arstechnica.com/apple/2015/01/why-dns-in-os-x-10-10-is-broken-and-what-you-can-do-to-fix-it/

Their "fix" is only for the exceptionally brave/foolhardy.

2
  • That's a good call. I started seeing it with iOS 7. So it's probably related to AWDL. I'll try WiFried on my Jailbroken device and see if it helps.
    – awfulcode
    Feb 8 '15 at 19:35
  • Alright, so it's definitely AWDL-related. I installed WiFried on my jailbroken device, and simply turned off AirDrop on the other devices. Haven't seen the problem show up ever since. Apple really messed up on that one...
    – awfulcode
    Feb 9 '15 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.