1

We have a MacPro connected to a Verizon FIOS modem/router. We are trying to connect to it via ssh remotely. It is set to listen for ssh on port 23. It works fine using LogMeIn Hamachi.

But using the public IP address, we cannot get the computer to respond.

We tried setting it up like this: enter image description here

But we keep getting Operation timed out

8
  • Why are you listening on port 23?
    – EEAA
    Jan 25 '15 at 23:43
  • Because we have port 22 forwarded to another machine
    – Dan
    Jan 25 '15 at 23:48
  • Well, you should probably start performing some packet captures and/or examine firewall logs to see where things are breaking down. There's no way for us to give you any further recommendations with the information you've provided.
    – EEAA
    Jan 25 '15 at 23:50
  • Hamachi doesn't need port forwarding to work, are you certain the port-forwarding is working, rather than Hamachi doing fine without it?
    – Paul
    Jan 26 '15 at 2:08
  • @Paul, maybe I wasn't clear: It already works fine with Hamachi, no forwarding needed. But we want it to work globally without having to use Hamachi.
    – Dan
    Jan 26 '15 at 2:11
2

Aha! Figured it out.

In the router port forwarding configuration, you have to set

  1. Source Ports: Any
  2. Destination Ports: the port you want to use
  3. Forward to Port: Same as incoming port
1
  • "Source ports: Any" solved this problem for me as well. Sep 26 '17 at 20:38
1

What worked for me (e.g., ssh user@WAN_IP -p CUSTOM_SSH_PORT)

Select IP from Menu: pick the server to port forward: note, assigned static IP

Application to forward: Custom Ports

Click "Advanced >>>" button

Source Ports: Any

Destination Ports: CUSTOM_SSH_PORT

Forward to Port: 22

The entry after being added reads:

Destination Port: CUSTOM_SSH_PORT TCP Any -> CUSTOM_SSH_PORT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.