I have created a Windows 7 VM using vmWare Workstation 10 on a Windows 7 host computer. The host computer has three LAN connections. The VM accesses two of them via bridged networking, which works fine. The last network must be accessed via NAT because I can't just add a new "real" device to this network. Also I may only use static IPs, not the DHCP server of Workstation. The problem is, I can only ping the host machine. All other computers on the network don't respond. When using tracert I can see that when pinging the host machine, it successfully connects to the standard gateway of the NAT connection and then proceeds to the IP address of the host. When using tracert to any other computer in the network, it doesn't even get to the standard gateway.

The next funny thing is: I then copied the VM from computer A to computer B in the same network. Booting up the VM on computer B (having configured the virtual network editor settings to match those on computer A) I can't ping the host (computer B). But what I can ping is now computer A, but still no other computers on the network. But if I try tracert to computer A from computer B, it just times out.

Any ideas?

Edit: I tried tracert again from the VM on computer B to computer A. This time it worked, but not in a way I would have expected: The first three hops just gave me request time out, but then, in the fourth hop, it connected directly to computer A, without going over the standard gateway of the NAT or whatsoever.

Also, I can in fact always ping the IP of the host assigned for the virtual adapter. So if my VM has and the host, I can ping to the latter from the VM.

  • Ok, I think I could narrow the problem down to the guest system. I temporarily turned on the DHCP server and let the VM automatically assign an IP address. All works fine then. But not with a static IP, even though I correctly set IP, subnet mask and standard gateway. – dudenr33 Jan 26 '15 at 10:02
  • Have you checked for ICMP ? I mean maybe the icmp is blocked from those computers and it is just enabled on A . – TechLife Jan 26 '15 at 10:19
  • I can ping all computers in the network from both computers, so it should be enabled. Also, those two computers are pingable from other computers in the network. – dudenr33 Jan 26 '15 at 11:09

I was able to solve my problem by using Windows troubleshooting for the networks. Unfortunately I can't give more detailed information since it didn't tell me what it did exactly and the settings still look the same.

Edit: After doing this I could no longer ping the devices on the other, formerly working network.

I have now (hopefully) found a better working solution. In both networks, I had set a standard gateway. As soon as I disabled the gateway in one of the networks, both worked. For the network with disabled gateway I added the routes manually with a script which is run at startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.