I am trying to run an x86 Android Virtual Device using Intel Virtualization Technology and VT-X. These features are required for the emulator to run correctly. However, I can't seem to get it to work.

The very strange thing about this is that the OS always appears to contradict my BIOS settings. When both features are enabled in the BIOS, Windows thinks they are unavailable:

enter image description here

On the other hand, when they are both disabled in the BIOS, Windows thinks they are available. Unfortunately I still can't start the emulator despite the OS thinking the features are available, since they are effectively disabled in the BIOS. Under these circumstances, I get this error message when I try to launch the emulator:

Starting emulator for AVD 'x86_10-inch' 
emulator: device fd:1096
HAX is not working and emulator runs in emulation mode
emulator: VT feature is not enabled, HAXM not working.
creating window 0 0 845 528

Sometimes, after restarting what appears to be an infinite number of times, I randomly get it to work. I'm sort of at my wit's end, this problem makes working really inefficient. Any help would be really appreciated!

To clarify, pure emulation is not an option. The only way to achieve decent speed is to use HW virtualization. When everything randomly works correctly, I am able to launch the virtual device with HW virtualization and it works pretty well.

My specs:

Asus N56J, Intel i7-4700HQ 2.4GHz, Windows 8.1 Pro, 8GB RAM


For anyone who may still have this issue, I've successfully resolved it. The problem is caused by the fact that Intel Virtualization Technology and Hyper-V cannot run at the same time. There are several possible solutions, pick the one that best fits you:

  1. Completely disable Hyper-V in your system.

    This can be done either by opening Control Panel -> Programs and Features -> Turn Windows Features on or off and then deselecting Hyper-V in the list, or via the command prompt by using the command:

    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

    Note that this operation requires a command prompt with elevated privileges (i.e. admin mode). To re-enable Hyper-V, use the command:

    Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All
  2. Prevent Hyper-V from running on system startup

    This way may be more comfortable for those who occasionally need Hyper-V (e.g. for Windows Phone emulation). To prevent Hyper-V from starting automatically, use the command:

    bcdedit /set hypervisorlaunchtype off

    To re-enable automatic start, use the command:

    bcdedit /set hypervisorlaunchtype auto

    Again, this requires a command prompt window with elevated privileges.

    All of these commands require a reboot before they take effect.

  • VirtualBox wouldn't start some existing virtual machines after I upgraded Windows. This was the issue. Good instructions. – chappjc Sep 7 '15 at 20:20

I had a similar issue. VT-x features locked or unavailable in MSR. VERR_VMX_MSR_LOCKED_OR_DISABLED. I run the VMBox for years and not this... I checked all the Forums and nothing helped me, than I realised there was an update of my antivirus software. So problem came from the new AVAST antivirus software. In AVAST Options-> Troubleshooting->Disable Hardware Virtualisation

After a reboot I could start my VirtaulBox again, VT-x features were no longer blocked.

I hope this post help some of you too.

Greetings Martin

  • Thanks! Spent hours today trying to figure out what's wrong. Everyone pointed out BIOS issues so I kept trying to turn stuff on/off settings and resetting the CMOS thinking my motherboard is dying. Nice to see Avast decided to give out a update with huge side effects without visible warning. Think it's time I uninstalled it, only ever useful for that one boot-time scan I did years ago. Way more trouble than it's worth. – Jahed Feb 10 '16 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.