5

I am trying to set the time, using e.g.

date -s "11/20/2003 12:00:00"

however, after a few moments, the system time resets to the current time. What am I doing wrong?

NTP should not get a different time, as this is a NTP server that has no connection to any other NTP server.

1

if you have the npt > apt-get install ntp. You must stopping or uninstalling the service doesn't help.

timedatectl set-ntp 0 (off > sync disabled)
or     
timedatectl set-ntp 1 (on > sync enabled)

Disable with timedatectl set-ntp 0 then you can change date:

date --set 1998-11-02 
date --set 21:08:00

see Maintaining Time on Debian - Datetime and NTP client and server

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.