1

I have the following Autohotkey mapping to attempt to open the Open TCP/IPv4 properties:

#w::
    Run ::{7007acc7-3202-11d1-aad2-00805fc1270e},, max
    WinWaitActive, Network Connections
    Send {Space}w{AppsKey}
    Sleep 250
    Send {Down 9}{Enter}
    WinWaitActive, Wi-Fi Fijo Properties
    ; FIXME: Move down to Ip4/ try to move someway here
    SendInput {Down 10}
    Return

However, as it can be seen in the Gif, when I press WinKey + w the SendInput {Down 10} command doesn't work and the the cursor stays highlighting the first entry Client for Microsot Networks). How can this be fixed?

EDIT: Updating autohotkey to the latest version seems to have fixed my problem.

enter image description here

11
  • Send vs SendInput?
    – meatspace
    Commented Jan 27, 2015 at 15:35
  • 1
    @petobens, I re-created your script and I used Send {Down 7}, worked fine for me and it opened my IPv4 Properties. What does Window Spy show when you run the script?
    – paradd0x
    Commented Jan 27, 2015 at 15:51
  • 1
    @petobens netsh, ipconfig, wmic?
    – STTR
    Commented Jan 27, 2015 at 15:52
  • 1
    @petobens But what you do - is unreliable. If this is to demonstrate, then there are powerpoint ...
    – STTR
    Commented Jan 27, 2015 at 16:05
  • 2
    @petobens it would be good if you could post your fix as an answer rather than an edit to your question.
    – Mokubai
    Commented Oct 11, 2015 at 11:17

1 Answer 1

0

This worked for me. For EXE created, I right-clicked and Run As Admin

#SingleInstance force

;; https://autohotkey.com/board/topic/62277-is-there-a-simpler-way/ ;; PLUS Open TCP/IPv4 properties with Autohotkey

Run ::{7007acc7-3202-11d1-aad2-00805fc1270e},,

;; max

sleep, 1000 ; 1.0 sec

;; mimics a right click on NIC icon - which at the end, 8 lines down, is Properties

Send {Space}w{AppsKey}

sleep, 500

Send {Down 8}{Enter}

sleep, 3500

;; move down to IPv4 line - for me it was 4 lines down ; for others, it maybe different

Send {Down 4}

; click the 'Properties' button, either method should work - using ControlClick ; but they both didn't ; -- correct control name (classNN - ie Button#) or correct control Text (&Pro&perties) are Important ; from WINDOW SPY

; ControlClick, Button4 , IPv4 Properties ;; this Button name didnt work for me

;; ControlClick, &P&roperties , IPv4 Properties ;; this control TEXT name didnt work for me

SendInput {TAB}{TAB}{ENTER}

exitapp

1
  • Use the formatting options in the post editor to make your code and answer more clear. Commented Jun 28, 2020 at 3:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .