1

So I restored my computer last night using Time Machine (I have Yosemite). My Google Drive folder didn't sync for some reason and it said

"Your Google Drive folder is missing"

So I located the folder and then it said:

"This is not your original Google Drive folder. Please find and select the original."

What I did next was disconnect my Google Drive folder. Then tried to reconnect it, hoping that there was an option to find it but I can't.

Is there anyway to just "locate" my current Google Drive folder? I have about 50 GB in there and I really don't want to have to re-download any of that.

3

I did not even need to re-intall G Drive. This is what I did, which worked smoothly:

  1. I have disconnected my account through the Drive application and GD warned me that he was leaving the GD folder intact.
  2. I signed in again and the application asked me to use the pre-existent Google Drive folder, which left as it was. I said yes.
  3. GD started a process to check which file of the folder it needed to sync. As the folder was left intact, after about 15 minutes of checking, GD told me that all was fine, no sync needed.
  4. That's all.
1

Just ran into the same problem. What worked for me (after disconnecting) was this:

I (re)downloaded Google Drive (https://www.google.com/drive/download/)

When I tried to drag it into the Apps folder, it said there was a newer version there already. I ignored the message, but to play it safe I let it add it without deleting the old/"newer" one.

I opened and installed the one I just added (automatically titled Google Drive 2). It asked me to login. I did. And the next thing I knew it was accessing the very same local Google Drive it had had that peculiar allergic reaction to before.

Hope that works for you, too.

0

I know you asked this question for Mac but it's the same for Windows. You get the 'This is not your original Google Drive folder. Please find and select the original.' message when the inode number of the Google Drive location doesn't match up in the Google Drive settings. In my example, I copied everything from a failing hard drive and gave the new, cloned hard drive the same drive letter as the old one, so the path for Google Drive was still the exact same (E:\Users\georgiecasey\Google Drive) but Google still gave that 'not your original Google Drive folder' error message as the inode number had changed.

You need to change inode number in the sqlite settings DB. Details in this great blog post: https://berezovskiy.me/2014/04/moving-google-drive-folder/

0

I'm on a mac and what I did was quit Google drive, rename the original folder (google drive 2) and then run google drive app again. On seeing there was no folder it created one, and then tried to start syncing. I then quit the app, copied all the contents from the renamed folder to the newly created one and then fired up the google drive app once again. It saw all the files there and then spent about 10 minutes synching them up - checking their integrity.

All was well and it saved a 50 odd gig syncing session! (and my data allowance!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.