1

Relevant file contents: http://pastebin.com/6VtWcaWG

Everything else including the aliases and the PATH variable are fine, but when I log in as root on my remote machine, the correct $PS1 (set in the remote machine's .bashrc) doesn't take and my prompt is different.

(I am not trying to push out my local PS1, this has to do exclusively with the remote host.)

EDIT: When I run bash after logging in, the correct variable takes, and my prompt is as expected. I therefore suspect SSH is later setting my prompt, but couldn't find a setting like that in sshd_config.

  • ha, same for me :) – Vao Tsun Jan 13 '16 at 13:00
0

There should be:

  export PATH=...
  export PS1=....
  • Changing that didn't help. Like I said, everything is as normal if, after I log in, I execute the command "bash" to get a new shell inside the original with the odd prompt. – Thisguy_ Jan 28 '15 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.