0

We have 2 servers, a Domain (Server 1) and an Application (Server 2) server. We are attempting to open an port on the Application Server to be accessed externally.

Server 1 is running Windows Essentials 2012, and Server 2 is running Windows Essentials 2012-R2. Because they are on the same network, Server 2 has not been configured properly as an Essentials Server (the only roles it is using currently is Application Server roles) to remove any possible conflicts with Server 1.

We have an IIS set up on Server 1, using remote web access, that can be used to access the server externally. The IIS on Server 2 has not been modified (it is still displaying the default page), and we cannot access it externally, which is the goal.

What we have tried so far:

  • Open an external port (8080) through the Router (D-Link DSL-2730B) and link it to an internal port (80) on Server 2
    • We have done the same for Server 1, which does work (have tried multiple ports, eg. 8080 - 8084)
  • Tried disabling windows firewalls completely on both servers
  • Ran a Telnet on an opened port (8086) to Server 1 (went through fine)
  • Ran a Telnet on an opened port (8087) to Server 2 (timed out)
  • Ran a Telnet on a port that was not set up (connection refused)

Here are our site binding for Server 2

enter image description here

Here are the current open ports set up in the D-Link

enter image description here

0

I got it working!

I ran an ipconfig, and it showed this:

Default Gateway.....0.0.0.0 
                    192.168.1.1

To remedy this, using Powershell I removed the Default Gateway:

route delete 0.0.0.0

Then I re-added it as the only Gateway:

route add 0.0.0.0 mask 0.0.0.0 192.168.1.1

Now I can access the IIS from Server 2 externally through the port the port we have defined.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.