0

I have a Windows 8.1 and I want to change the fonts of command prompt. I open the properties window, shown below

Raster Fonts

However, I can't find what I want. I open the registry editor to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont]

And here are

00  Consolas
0 Lucida Console

Why can't I see them in property windows of the command prompt?

  • One thing you can try is re-installing the two TrueType fonts by dragging them out of the Fonts folder and back into it. – Peter Hahndorf Jan 28 '15 at 11:01
  • I tried, however it still doesn't work. – Sir Underhill Jan 29 '15 at 5:24
1

Fonts have to be specifically added to a different part of the registry to be seen by the console.dll (which shows the properties).

Think of it as a UI feature from Windows 2.x they have not got around to 'fixing' yet.

  • I'm still laughing......... – Moab Jan 29 '15 at 2:04
  • Sorry for my English, but i don't get much information here except MSFT is not caring user experience too much or at all. – Sir Underhill Jan 29 '15 at 5:25
  • howtogeek.com/howto/windows-vista/… You have to add fonts into the registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont – wendy.krieger Feb 15 '15 at 8:45
0

Standard Windows terminal allows and uses only those fonts which are "Monospace". So, may be your fonts was broken or patched, or you've installed some third-party software which changed standard fonts behavior. Try to undo changes made in your system.

Also you may try to use other terminal emulators like ConEmu or ConsoleZ, they do not have such restrictions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.