0

I usually keep the updated on "Notify only" setting but still Windows is keeping an svchost.exe process running in the background all the time, which very often connects to a Microsoft Update server (134.170.165.249) which spikes CPU to maximum.

It happens especially when I come back from Standby, significantly affecting the ability to resume the work instantly.

Is there a way to completely turn off the Update, so that doesn't even do checks? I only do manual updates so it's useless for me to know that updates are available anyways.

0

You can use the option Do Not Check At All to disable the update check. (Never check for updates (not recommended) from the drop-down box under Important updates to completely disable automatic downloads, installations, and even checks for updates.)

Steps below:

1.) Open Windows Update by clicking the Start button Picture of the Start button. In the search box, type Update, and then, in the list of results, click Windows Update.

2.) In the left pane, click Change settings. This will open a window with a Choose your Windows Update settings heading.

3.) Under Important updates, choose the option that you want - Do Not Check At All

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.