it's quite popular problem and I've seen many solutions, but none of them worked for me. I've created virtual machine with Ubuntu 14.04 and haven't changed anything in Ubuntu configuration. With NAT I have internet connection in guest, but when I change network type to Bridged there is no internet connection on guest. Host works normally. The same problem is with machines created via VMware Player. I have installed VMware Player after working with VirtualBox so VMware Player network cards is not causing this problems. But sometimes I use vSphere Client, which was installed before VirtualBox and maybe this could cause this problem, but I haven't seen any network cards created by vSphere which could cause conflicts. Just in case I've turned off all network cars excluding host and VirtualBox network cards. Same result. VirtualBox Bridged Networking Driver is enabled.

Network card selected in Bridge configuration is the same card used by host system. Host internet connection is wireless, but when I tried to use wired host internet connection result was the same. I've tried turning firewall off, turning antivirus off and many other solution which I've found. Still no internet connection on bridged guest. I've sat with our network admin for more than hour and we still don't know what is wrong. All ideas are welcomed.

Something must be wrong on Windows 7 host side, but I have no idea what it could be.

In case it could be useful I am posting basic info from Ubuntu guest (Bridged Networking):

tomek@tomek-iic:~$ ifconfig

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:da:b6:6d brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:feda:b66d/64 scope link 
       valid_lft forever preferred_lft forever

tomek@tomek-iic:~$ cat /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

tomek@tomek-iic:~$ ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 08:00:27:da:b6:6d brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a00:27ff:feda:b66d/64 scope link 
       valid_lft forever preferred_lft forever

migrated from serverfault.com Jan 28 '15 at 16:21

This question came from our site for system and network administrators.

  • Are you using DHCP in the guest? Can you post guest's /etc/network/interfaces ? – Mauricio López Jan 28 '15 at 17:47
  • @Mauricio As far as I Know DHCP is disabled just like it should be in Bridged Network. Guest /etc/network/interfaces and other infos are posted in question. ; ) – ctomek Jan 28 '15 at 18:37
  • I asked about /etc/network/interfaces because there should be some configuration in that file for the eth0 interface and I only see lo. How do you add the ip address to the interface? And set the link up? And write the routes? All manually or are you using NetworkManager? – Mauricio López Jan 28 '15 at 22:19
  • @Mauricio I have made no configuration changes in Ubuntu after installation. Ubuntu have network manager intalled by default and it handles network so all current network configuration is made by network manager bundled with Ubuntu. Some time ago I created virtual machine on VirtualBox with different Windows 7 host and Bridged Network worked out of the box so it's strange that with my current host it doesn't. – ctomek Jan 29 '15 at 7:47
  • @Mauricio I've found solution, my answer is below. Thanks for help anyway. ; ) – ctomek Jan 29 '15 at 11:17

Check you're binding to the right interface. If you're using wireless then your ethernet port on host will appear as disconnected and the bridge won't work. I've used to have this problem using VirtualBox on Windows 7

  • If that answers your question cat /sys/class/net/eth0/operstate returns "up" so eth0 is up. But I am not sure if I understood your question. Yes, ethernet port is disconnected, but in virtual machine network options I have set wireless network adapter as host adapter so this should be enough. With that Ubuntu is only aware of working wireless network adapter and doesn't know about disconencted wired adapter. Correct me if I'm missing something. – ctomek Jan 29 '15 at 8:07
  • I've found solution, my answer is below. Thanks for help anyway. ; ) – ctomek Jan 29 '15 at 11:18
up vote 0 down vote accepted

I needed to set static ip to guest machine and it's working!

  • 1
    Any more detail on how you accomplished this? What IP did you set it to, etc? Did you use the GUI or command line? How? Help appreciated! – elsurudo Sep 18 '15 at 18:26
  • Any free IP in your local network will be ok. In Ubuntu to set static IP you need to change one or two config files and maybe do something more, I don't remember it right now. Just google "ubuntu static ip" and you will find out exactly how to do this. – ctomek Sep 19 '15 at 12:10

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.