I would like to migrate an existing OSX 10.9.5 machine to a 10.9.5 Guest VM running on a 10.10.1 host.

My situation is: I own a 10.9.5 MBP that I use everyday. I have development tools on the machine that I am not sure work on Yosemite. I bought a new MBP that runs 10.10.1.

I would like to migrate the old machine en-masse to as a guest machine, then I can migrate piecemeal off of the VM onto the native machine.

I have tried several things, but these instructions seemed most promising:

  1. Build a simple guest machine using "Install OS X Mavericks.app".
  2. Boot that VM using safe mode.
  3. Connect my USB based Carbon Copy Cloner Bootable image.
  4. Start OSX migration assistant (not VMWare migration assistant).
  5. Chose to migrate from CCC.
  6. wait.

I have not been successful.

The immediate problem is that the USB drive is not visible to the VM so I am stuck at Step 3. usb mount problem

Apple support politely denied help as soon as I said VMWare.

  • If you have a network at home, can you create a network boot disk? It's been well over a decade since I've done this (on a PC I might add) but we used to push up and pull down images this way using Ghost (this was also when harddriver were well under 250MB. Ghost has since been purchased and sold a few times so I don't know if it is still the great program it once was.
    – HPWD
    Jun 2 '16 at 12:37

This is how I did it:

  1. Create a Image File on an external drive (Sparse Bundle, so the size of the original drive can be variable
  2. On the source machine, use SuperDuper or CCC to copy the drive to the image file/bundle
  3. Using Fusion 8.5 create an OSX VM using the recovery drive
  4. Add an additional drive to the VM
  5. Mount the external drive into the VM
  6. Mount the image file on the external drive
  7. Use SuperDuper or CCC to copy the mounted image to the additional drive created in 4
  8. Set the startup disk to be the copied drive
  9. Stop the VM, delete the original drive, restart, and you should have your original machine in a VM.
Apple support politely denied help as soon as I said VMWare.

Sounds about right. While it's EUAL contractually legal to run OS X in a VM, Apple will scoff at you for this.

I'm assuming you're using at least an N-1 version of VMware Fusion. I've had success with this general process:

  1. Backup your OS to any external drive using Time Machine (ditch CCC for this exercise)
  2. Create a new VM using "Install from image" and select More Options.
  3. Choose "Install OSX from the Recovery Partition"
  4. Follow the prompts and once you're in the Recovery partition, elect to restore from Time Machine.
  5. Once you're confident your data is in the VM, upgrade your host to Yosemite. NOTE THAT you'll need to upgrade to Fusion v7.x to run on an 10.10 host.

The other option is to just build the guest VM the same way and cp the files over once you have networking setup. The challenge here is file ACLs and ownership. Plus the whole app reinstall hassle.

Hope this helps.

  • I had tried the method of using a time machine backup to restore. The process would die mysteriously and return to a login screen. I captured the console log and found nothing suspicious that would indicate why the process died. It ran about 8 minutes before it would die. I posted that on the vmware site and someone suggested using a CCC backup as a solution. Note: My host is Yosemite. Can you go over the importance of having the host match the guest? Jan 29 '15 at 13:52
  • Note: It's only allowed to run OS X in a VM when that VM host is OS X running on an Apple computer.
    – slhck
    Jan 30 '15 at 14:26
  • "allowed" is the key word. I was able to run VMware ESX on a Mac Pro and host Yosemite VMs. It's not supported but that's what StackExchange is for, right? ;-)
    – SaxDaddy
    Oct 27 '15 at 21:21
  • @SaxDaddy Why does the page en.wikibooks.org/wiki/VirtualBox/Setting_up_a_Virtual_Machine/… say that it's not legal?
    – Pacerier
    Mar 18 '18 at 17:38

Since your external drive is a bootable clone, another option should be booting your VM from that external drive, and then cloning to the VMs drive rather than migrating.

Of course, this may run into the same USB hurdle because that seems to be the real issue here, but it's worth trying.

(Historically, at least) Fusion does not allow you to boot directly from a USB drive without a third party tool such as the Plop Boot Manager, which is a small, bootable disk image allowing you to then boot from the external drive.

From http://kb.mit.edu/confluence/pages/viewpage.action?pageId=12386368:

  • Visit the download site and download the latest .zip file containing the Plop boot manager.
  • Extract the Zip file to a temporary location on your hard drive. It will create a folder called "plpbt-<version>".
  • In the top level of the extracted folder, you'll find a file called plpbt.img. Copy that file to your Documents folder. You can delete the .zip file and the extracted folder.
  • Launch VMWare fusion, and open the Settings for the VM you want to use. Under "Other devices", add a Floppy drive, configured to use this .img file.
  • Go to "Advanced Settings", and configure the VM to boot from this new floppy drive.
  • Plug the USB device into your Mac, and connect it to the VM using the "Virtual Machine" menu -> "USB" -> "Connect <name of your USB device>"
  • Boot the VM. You'll see an image of a star field, and a menu in the top left. Choose "USB" from that menu and hit enter, and the VM should now boot off the USB device.

I had this problem too. USB devices would be seen inside the OSX VM (if I checked the "system report" they would show up) but never actually seen as disks by OSX. Smaller capacity memory sticks would be fine, but the larger HFS+ volumes would never come online - In my case I used OSX 10.15.5 and also tried OSX 13 as the host and as the guest. I spent about a month trying to get a Time Machine backup connected to a VMware machine. Any time machine backup connected to any VMware machine! When that didn't work I tried to connect any USB hard drive to the VMs and that didn't work. I re-did the VM in multiple different Macs several times using several versions of OSX.

In the end I installed Parallels version 15 and it worked on the first go. Problem solved. I could migrate the VM from Parallels to VMware now I suppose but I think I'm going to be keeping Parallels and using that moving forward.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.