5

I have a Yosemite (10.10.2) host with a Mavericks (10.9.5) guest in VMWare 7.

I have a seagate 3TB drive mounted on Yosemite.

I connect the seagate to the guest using the icon on the toolbar. The icon for the drive disappears off of the Yosemite desktop, but never appears on the Mavericks desktop.

In addition, it can not be seen in these places (on the guest) either:

  • in the sidebar of finder.
  • In /Volumes
  • In Disk Utility.

Here is what I tried:

1) I tried rebooting the guest several times.

2) I tried repair disk on the usb drive.

3) I tried disconnecting and connecting several times.

4) I tried unmounting it from the guest and host, then disconnecting and reconnecting while the guest was connected.

5) I tried looking in console for any errors related to the disk.

In summary: It will appear as connected in the icon on the toolbar of vmware, but will not appear in the guest.

The contents of the disk is a Carbon Copy Cloner bootable image.

3
  • Did you ever get a solution to this? If so, please post it as an answer.
    – Old Pro
    Mar 16 '17 at 0:20
  • I never found a solution. Mar 16 '17 at 19:38
  • I am experiencing the same issue, though with OS X 10.9.x Mavericks host and macOS Sierra 10.12.4 guest and LaCie D2 USB3 external hard drive. I have upgraded to VMware Fusion Pro 8.5.6 and it still persists. The odd thing is that the LaCie drive shows as connected to the USB3 bus in System Report under the guest OS.
    – morgant
    May 3 '17 at 21:40
1

I dont know if this problem is still up to date, but here is a solution I found which works pretty well:

First of all we should to figure out our hard drive name:

launch Disk Utility (select Finder, click on the Go menu, select Utilities, launch Disk Utility.app)

Select your hard drive and press Info button on the top-left.

Remember the Disk Identifier specified in the Information window ("disk1" in my case).
Fire up Terminal.app (it is also located in the Utilities folder) Change current directory in Terminal to the WMware.app Contents/Library folder (you can simply copy and paste the following line:

cd "/Applications/VMware Fusion.app/Contents/Library/"

Now we should create a .vmdk file that will point to our external hard drive:
paste the following line into the terminal (change disk1 to the disk name you've found in the step 1):

./vmware-rawdiskCreator create /dev/disk1 fullDevice ~/external-hdd ide

This will create a new external-hdd.vmdk file in your home folder.
OK, we're almost done. Now let's find our VMware guest OS container and add to it just created link to our hard drive.

  • Open Finder and go to a folder where your virtual machines are located. (Documents › Virtual Machines in my case)

  • Do a right click on desired Virtual Machine to display a pop-up menu, select "Show Package Contents" this will allows us to view a directory with all corresponding files to this VM.

  • Move or copy external-hdd.vmdk from your home folder into this one. Do a right click on a file named like current VM with .vmx extension, select Open With › TextEdit

  • Scroll to the end of file and add the following lines:

    ide1:1.present = "TRUE"
    ide1:1.fileName = "external-hdd.vmdk"
    

    Save and quit

That's it, now you can launch VM with attached external HDD or SDD!

0

Note: This a comment but I do not have the rep to post one officially here, yet. I'm more than happy to delete it/have it deleted after the OP has seen it (or have it converted, if that is possible).

It may be worth knowing what the advance USB options are for this virtual machine (Settings -> USB & Bluetooth -> Advanced USB options). There is also the Enable Verbose USB debugging option under Settings -> Advanced which could be helpful here.

1
  • Same problem here. A year later my OSX 10.11.4/Fusion 8.1.0 suddenly, like last week, stopped letting me access my development Android devices from a VM. This is Fusion, the only advanced option you could try flipping USB 3 or 2. USB logging doesn't show anything, because it doesn't attempt to mount anything...
    – dubmojo
    Apr 24 '16 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.