0

How do i run a fsck command on a partition (disk0s4)?

I tried »fsck -fy« in single-user-mode but it only checks the boot partition (disk0s2) which is ok. »fsck -fy /dev/disk0s4« does not work: »fsck usage: fsck [-fdnypq] [-l number]«

(I ran diskutil and Disc Utility before but it could not verify or repair the partition. »OSX can´t repair the disk. … backup, reformat …« after the boot.)

Many Thanks, Anna

  • Yes fsck is your last chance, but boot in single user mode first. See osxdaily.com/2013/08/07/… – Jean-Baptiste Yunès Jan 29 '15 at 12:27
  • Thanks, did that already! The problem is that I can´t figure out how to run the fsck (in single-user-mode) on the broken partition, which is still readable but not writeable. – anna Jan 29 '15 at 12:33
  • What do you mean by not writable ? Don't you use a root account to run fsck ? – Jean-Baptiste Yunès Jan 29 '15 at 13:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.