1

If I enable both hidden and system files, and then select them all while in the C:\ Drive, the properties window adds their data up to 220 GB. However, if I right click on the C:\ Drive itself and select properties, I have 300 more GB than what was shown previously.

Screenshot

Where is this other 300 GB of data coming from? Is it something vital to the OS? Is it something that's still hidden somehow?

  • When you are selecting files and seeing 22 GB, are you looking at "Size" or "Size on Disk"? The latter is what shows for the hard drive. – NextInLine Jan 29 '15 at 20:01
  • Try looking at the "Disk Management" windows plug-in, see if it reports additional hidden partitions or anything. (Asus did this at one point if I recall - half the hard-drive was used as a "backup partition") – NextInLine Jan 29 '15 at 20:04
  • Are there multiple user profiles on the disk? – Rowland Shaw Jan 29 '15 at 20:04
  • @NextInLine 1) See the screenshot, size on disk is 220 GB. 2) The question is about a single partition's size and usage. Other partitions don't count in. – gronostaj Jan 29 '15 at 20:06
  • It may be a filesystem problem. Try running a disk check, instructions here. It's your system drive, so you'll have to reboot. – gronostaj Jan 29 '15 at 20:07
2

Selecting all files and showing properties skips files where don't have access to. Run TreesizeFree (as admin) and look which folders "eat" most space.

enter image description here

| improve this answer | |
  • Holy crap -- System Volume Information is taking up 295 GB. Screenshot Is this data usage necessary? If not, what could be bloating my hard drive and how could I remove it? – Drew Jan 30 '15 at 12:41
  • @EchoFive Check out the "Best Solution" here. – NextInLine Jan 30 '15 at 16:02
  • this is the folder where the system restore points data are stored. In the control panel, you can reduce the size and clean them – magicandre1981 Jan 30 '15 at 16:24
1

The pie chart gets its information from the $BITMAP metafile which shows which clusters are in use or not. It is 100% accurate.
The properties in Explorer relies on the user having permission to access the folders and files and can go wrong in all sorts of ways.

You can find extensive explanations here:
http://blogs.technet.com/b/askcore/archive/2013/03/01/where-did-my-space-go.aspx
http://blogs.msdn.com/b/ntdebugging/archive/2008/07/03/ntfs-misreports-free-space.aspx http://blogs.msdn.com/b/ntdebugging/archive/2008/10/31/ntfs-misreporting-free-space-part-2.aspx http://blogs.msdn.com/b/ntdebugging/archive/2014/05/08/ntfs-misreports-free-space-part-3.aspx

| improve this answer | |
1

A few explanations and suggestions, but first, do a disk check chkdsk c: /f like others have suggested.

  1. Get a program that is designed to show you what is eating space on your drive, an example is WinDirStat. Run it as administrator.

  2. Even Administrators cannot access certain folders such as C:\System Volume Information, which stores the system restore data. You can check its usage in Control Panel -> System -> System Protection.

  3. File streams and NTFS metadata files don't show up even when you show all hidden and system files.

  4. If you recently used NTFS built-in compression to compress/decompress large number of files, the disk usage stats may not be correct. Rebooting fixes this. (This is just my personal experience and I have not investigated further.)

| improve this answer | |
  • I've run the full chkdsk as you and others have suggested, but that didn't seem to make a difference. It appears even the built-in administrator account running WinDirStat as an administrator doesn't have access to some directories (I assume that's what the red means). Screenshot I suppose that is the issue, as others have pointed out that only directories you have permission to will be counted in the data size. I'm still surprised that I'm not able to access those directories even with the highest permissions on my computer. – Drew Jan 29 '15 at 23:04
  • @EchoFive: There is one more user account you can try. See Getting a CMD prompt as SYSTEM (I used the PSEXEC method). After you get a cmd prompt as SYSTEM, run WinDirStat again and search. For me, it accounted for all disk usage. – Alex Jan 30 '15 at 18:13
  • If you can identify that the problem is the size of the "System Volume Information" folder, right-click on the Volume and see if there is an option for "Configure Shadow Copies...". If so, open it, select the desired volume and click settings to see if there is a Maximum Size set, or if it's too big. If you decrease the maximum size and click OK, you should see the volume use start to decrease. – Geoff Jul 20 at 20:14
0

This is likely to be due to the use of junction points.

Some of the data on the disk needs to appear in more than one directory, but it is the same data, so rather than duplicate the data it is made to look like it is in more than one directory.

When you get the properties of all the files and directiries, Explorer naïvely includes what appear to be separate directories, whereas the disk properties account only for actual usage.

Having said that, the 300GB difference seems to be somewhat on the large side (on my Windows 7 installation the difference is 78GB), so it may be a good idea to run a disk check, as gronostaj wrote, or use chkdsk c: /f from a command prompt run as Administrator.

| improve this answer | |
  • Explorer does not traverse into junctions to count the number and size of files, unless the junction points are specifically selected when the user did "Select All". In other words, it doesn't double-count unless you made it to. Also if junctions were the issue here, the size in the left side window in the OP's screenshot should be larger. – Alex Jan 29 '15 at 21:45
0

I think this is due to permissions.

If you can't read a file, you can't find the size of the file (left side screenshot).

On the right side screenshot, the APIs Explorer is using doesn't require read permissions to EVERY file.

The method on the left side screenshot doesn't add up files in folders that you can't read.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.