I have a friend's laptop running Windows XP SP3 which refuses to log in.

It has a single user account (besides Administrator) without a password.
Now, however, the Welcome screen shows the account as if it had a password, and any attempt to log in (even to Administrator, or to a non-existent username) results in the error message The system cannot log you on now because the domain D2NPL961 is not available. (D2NPL961 is the computer's machine name; it is not joined to a domain)

Safe mode doesn't change anything.

The Windows Classic logon dialog (Ctrl+Alt+Del) does not show the Domain dropdown.

I tried editing the registry offline (in ERD Commander) and making the domain name in Windows NT\CurrentVersion\WinLogon blank, but that didn't change anything.

I tried DreamPackPL, but it didn't affect anything. (Apparently, the error is too early in the logon process)

I tried setting the screensaver for the logon screen to cmd, and I was able to confirm that the machine name is D2NPL961, but I was unable to elevate to admin and do any good.

In the screensaver, the runas command produces the error 1056 An instance of the service is already running; I don't know if that's normal in this situation.

I'd like to try a repair install, but I cannot get administrative privileges.

Has anyone seen this before, or know what might be wrong?
Alteratively, how can I elevate to admin without logging on?

EDIT: To make it clear, the problem here is not a password.


Use the Offline NT Password & Registry Editor to reset the Administrator password, login as Administrator and see what happens. You may have to still edit the registry, but that should allow you to use the recovery console.


You should also just back up anything that you need to on that machine, chances are that even if you do get to the root of the problem that windows install is not going to not be quite right after fixing it. A repair installation should be fine, but it always sucks to lose data, back it up.

  • I've already backed up everything important. I don't need the recovery console (ERD Commander is infinitely better) and the problem here isn't the password. – SLaks Dec 24 '09 at 2:30

I booted the system to a Windows XP CD and performed a repair install from the CD.
It's now working fine (AFAIK).

I still don't know what happened, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.