1

I have a busy Desktop with dual monitors. I place a Word Doc in a particular position, I open the document, and then Word moves it to a random place. When I close the document in Word, it takes me some time to find the document again. Note: I am referring to an actual document, and not a shortcut.

There are a few related questions like Desktop icons keep moving around, but that seems to be more of a bug (the lockup/freeze). In this case, it appears to be a Microsoft Word "feature".

I'm using Windows 8.1 on a standard laptop with classic desktop view (not a tablet or touch screen with the Metro view). The version of Word is part of Microsoft Office Professional Plus 2013 (I can't figure out where the About Word... is under this new interface, so I can't state the actual version with a service pack level).

How do I stop Word from randomly rearranging the documents on my Desktop?

5
  • What version of Word and what version of Windows? Finding a solution for Windows 3.1 will likely be different than for Windows 8.1. :-) Are these shortcuts or the actual document?
    – CharlieRB
    Jan 30 '15 at 18:46
  • @CharlieRB - good point; done. And they are documents, and not shortcuts.
    – jww
    Jan 30 '15 at 19:28
  • I agree with @alex below about the reason why this is happening. I don't think there is a way to get around this while keeping the file on the desktop.
    – CharlieRB
    Jan 30 '15 at 19:47
  • This is great... I had a version 4 of a document. I copied it to version 5 and made some edits. Later, I deleted version 5 because Word thought it was OK to rearrange my desktop icons. F--k Word and the a--h--- at Microsoft who approved this f--k'ing feature.
    – jww
    Mar 4 '15 at 20:18
  • @jww: “Fool me once, shame on you; fool me twice, shame on me.”  Now that you know how the system behaves, and you have chosen not to use the suggested “work arounds” (i.e., you’ve chosen to go ahead and juggle flaming chainsaws), it behooves you to be extra careful.  … … … … … … … … … … … …  P.S. Profanity will get you nowhere. May 3 '15 at 18:38
1

When you save a file in Word, it actually saves to a hidden, temporary file first before replacing the original file. Word does it so that if it crashes during save, you don't lose the original. This also means that Windows Explorer sees the original file briefly disappear and forgets its position on the desktop.

If you just want to be able to open the same document by clicking at a particular place on Desktop, create a shortcut of the document on the Desktop.

5
  • "... create a shortcut of the document on the Desktop" - thanks, but I don't use my computer that way. I'd still have to find the original document to copy it to a shared drive when I'm done editing. It doesn't make sense to have the document on the desktop, and a shortcut to the document on the desktop.
    – jww
    Jan 30 '15 at 19:31
  • @jww: What about keeping the actual document on the shared drive, and create a shortcut of that and place it on desktop?
    – Alex
    Jan 30 '15 at 19:43
  • 2
    @jww: So you need to move a document to local drive, edit it, and move it back to the shared drive after editing? In this case, open an Explorer window and navigate to your desktop, change the View to Details and sort by Date modified. No matter where the document ends up after you save, it will be the top one in the Explorer window.
    – Alex
    Jan 30 '15 at 20:29
  • Thanks again, but I'm not interested in work arounds. I'm interested in fixing the problem with Word. The software should work with me, and not against me.
    – jww
    Jan 30 '15 at 21:36
  • @jww: You seem to be missing the point of what everybody is saying: This isn’t a “problem with Word”.  It’s an aspect of the interaction between Windows Explorer and Word.  “The software should work with me, and not against me.”  Yeah, well, Microsoft doesn’t play that way.  … … … … … … … …  You’ve gotten 3½ suggestions: (1a) Don’t use the Desktop,  (1b) Don’t put documents on the Desktop, just shortcuts,  (2) Turn off “Safe saves” (if you can figure out how), and (3) Stop showing hidden files.  I doubt that you’re going to get anything better that that. May 3 '15 at 18:36
1

It was a long time since I last had a look, but is "Safe saves" still available among the options? Is it turned on by default?

I'd say turning it off may be your answer.

0

The "Word moves desktop icons problem" has a long history on the web. When you save a Word file normally, Word creates a perfect image of that doc file with a name ~WRL*** and changes your original desktop icon to have this ~WRL name. If you have a Word crash later on, that saved file is perfect and is used by the recovery system or you can just use it directly. But when you close Word after doing a save, Word deletes that ~WRL icon and then creates a fresh original file icon at the next available desktop icon location, hence the original icon has moved on the desktop. I have found at least in Office 2003 Word with Windows 7 that this problem goes away if in folder options/view you say "don't show hidden files". Then Word does not mess with desktop icons at all and the original desktop icon stays where it was.

3
  • Sounds about half right.  I believe that Microsoft Office (including Word) knows nothing about desktop icons.  (If you can provide a reference to support your claim, please do.)  You’re right about Word “saving” a file by creating a new file (an edited copy), renaming it and deleting the original (as opposed to things like Notepad, which simply overwrite the original file).  However, the icons are handled by Windows (Explorer), not Word.  And this was discussed quite adequately in the first answer, over three months ago.  But your suggestion to turn off display of hidden files is worth trying. May 3 '15 at 18:19
  • Well yes, Word does not itself create desktop icons, it causes them to be created by the Explorer shell. The main point is that this fixed the problem of the moving Word icons, at least for my situation.
    – user443515
    May 4 '15 at 2:33
  • ARRGGGH! My fix has failed, it only works for some files, some kind of race condition. When it fails, doing a save creates a temp ~WRL desktop icon which lasts for about 1 second, then the original icon appears in "next available position" and the temp icon then vanishes. This is all with "don't show hidden files" activated. Oh well.....
    – user443515
    May 6 '15 at 20:57
0

I know this is super old but thought I would reply anyhow. I have this issue at work and when this happens I do the following.

  • open the word doc
  • copy everything
  • close it
  • move the annoying word doc to the trash
  • delete what's in the trash
  • open a new word doc
  • paste everything and resave it to my desktop

Not sure what causes this issue but this works for me every time. This is the only way I can get rid of the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.