0

Something happened with my USB flash disk and I had to format it. Every time I tried to format it, I've got: "Windows is unable to format" message.
I found a program SDFormatter and tried it. I don't know what happened after the format but every time I plug my flash memory it won't show in my computer.
I have got a new driver (USB Mass Storage) installed and opened disk management and I don't see the flash memory. :(
How can I get my USB Flash Disk to start working again?

1

As a Helpdesk technician I've seen this scenario several times. About 25% of the time the flash drive is just dead and won't ever work again. When this happens, plugging in the USB drive to either a Mac or Windows machine causes erratic results such as the machine freezing up, not booting, or the machine being exceptionally slow. The other 75% of the time, I plug it into a Linux machine or a Mac and format it FAT32. When I bring it back to Windows it works perfectly fine again and I can format it any which way I please.

Depending on the flash drive's actual dollar value, you might just want to get another one if you can't fix it quickly.

|improve this answer|||||
  • You do under stand he put another drive in there with the same issue. – Virusboy Jan 30 '15 at 21:57
  • @Virusboy - the OP referred to a driver and not a drive. I see no mention of trying a different drive in the same computer. – Craig Watson Jan 31 '15 at 0:21
  • @Virusboy, I see it the way Craig saw it, one USB flash drive being used during this scenario. I assumed that he or SDFormatter had Uninstalled the USB Input Device from Device Manager and when he plugged it back in, his system recognized a new USB device and installed the new instructions for the USB Mass Storage. This is closed, but if the OP had another Flash Drive handy, he should have plugged it in to see if it registered with his computer to get the troubleshooting going. – John Carr Jan 31 '15 at 21:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.