I recently restarted my computer, and when it started, it told me that application needed .NetFramwork 4.0 to run. After some poking around I also found .Net 3.5.1 is not there either.

So I thought it was a simple fact of reinstalling .Net. But when I tried to install .Net 4.0 and 4.5, I got this error (0x80070643). So I thought I need to install .Net 3 first, I tried to do that, but it told me to change the setting in enable windows features. When I opened it, it showed that .Net 3.0 is already enabled, I tried to disable it, when I pressed apply, it came up with an error, some features are not enabled, and told me to restart. When I did, I came back to the Enable Windows Features window. Found that it is disabled. But when I tried to install .Net 3 again. Still told me to change the Windows Features setting. When I tried to turn it on again, it failed, told me to restart, and still not enabled.

Things I tried:

Using the .Net fix tool
Using the .Net Cleanup tool, and reinstalling, .Net 1.1 worked fine, but not 3
Using the TFC Temp removal tool
Using Microsoft Fixit tool
Going into .NetFramwork folder, copying and changing the .default to .config, 
which is already there, but I changed them to .old, and put the default ones in
(For both the 32 and 64 bit folders)
Uninstalling SlimDX .NetFramework Files
Tried Installing .Net 2.0 sp2, same error, use "Enable Windows Features"
Tried this command "DISM /Online /Enable-Feature /FeatureName:NetFx3 /ALL /NoRestart"
cameback with error 87

All of them not working, .net-framwork 4.0, 4.5, 3, 3 sp1, 2.0 sp2. 1.1 and its sp did work though.

Any ideas? Thanks a ton!

EDIT: Did a verification test. In the log, every .Net Framework is marked as not installed, apart from .Net 2.0. Log File: http://pastebin.com/8E7jTBkG

  • I put some info here superuser.com/questions/575716/… and it has one link for the exact error number. Looks like you already tried all that. Note I usually avoid the "fix-Its" themselves, and instead look for the resolutions they will do and check manually. It has been said that installing 4.5 should be all you need, that installing 3 would not be nessiary. because one of them comes with the win7SP1 releace, could be a SFC /scannow thing might correct some issues out of the SxS install stuff.
    – Psycogeek
    Jan 31, 2015 at 6:23
  • @psycogeek, I backed up the config files, because I changed them maunally, but sadly I'm not quite sure what other files to back up.
    – 8176135
    Jan 31, 2015 at 6:38
  • @Psycogeek also tried to do a SFC scan, and failed :O, error,Windows Resource Protection could not perform the requested operation. Searched it up, someone said that it might be a problem with the disk, so I checked all the drives with chkdsk for C:, and through explorer for the rest. No errors though... Tried again, still not working
    – 8176135
    Jan 31, 2015 at 7:43
  • I'll try SFC in safemode, then I'll do the chkdsk /F, and a repair install after that, see what happens....
    – 8176135
    Jan 31, 2015 at 8:24

1 Answer 1


I can't believe it... A few month ago, I moved the Microsoft .NetFramwork folder to my D: drive, and made a symbolic link between them. I forgot about it, since it didn't cause a problem for months, but now I moved it back, it might be the reason it was fixed.

The way I fixed this:

Start in safe mode, try sfc /scannow in cmd.
If not working, chkdsk /f on all the drives.
Then, if the .Net folder is on another drive, move it back.
Try sfc /scannow, should work now.
Startup normally, run .Net cleanup tool
Then install .NetFramwork 4.5.2, not 4.0.

And it worked for me. Though your themes might be gone, and u will need to reinstall them.

Thanks Psycogeek for the help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .