1

When trying to install VirtualBox on Windows, I got the following error. The version is VirtualBox-4.3.20-96997-Win. I have reviewed this question and it's not the same issue. enter image description here

More info just says that the installer is not recognized. It also gives the "run anyway" option.It says "common.cab" is corrupted. I've downloaded 4.3.18 (The check sum is identical), and the installer finished but some how breaks the WiFi driver (connected but no network). The program also doesn't run for no apparent reason and I've tried several compatibility options.

  • Does it give any specifics in the "More info" link? – Dawn Benton Feb 1 '15 at 18:12
  • 1
    I have to wonder if your download is corrupt. No way a genuine VirtualBox installer would be unrecognized (unless perhaps Microsoft's SmartScreen service was temporarily broken). – misha256 Feb 1 '15 at 19:06
  • This particular problem has to do with the reputation of the file nothing more. – Ramhound Feb 1 '15 at 19:49
  • That was fixed. The point of this question though is any solution for Virtualization on Windows 10 – qballer Feb 1 '15 at 19:52
  • Sorry, we don't do software recommendations on Super User. It sounds like your download is corrupted. Note that VirtualBox installs additional network adapters and it may cause the "No network" icon to appear, but it doesn't mean that networking doesn't work. – gronostaj Feb 1 '15 at 19:52
3

What you see is a Windows SmartScreen warning. It doesn't recognize the file yet and thus doesn't want you to run it.

Click More info to reveal a Run Anyway button.

You could also disable SmartScreen completely if you feel like a superuser, but for most people it's best to just leave it enabled and bypass warnings once in a while.

| improve this answer | |
  • 2
    This is the correct solution to get around the SmartScreen warning, but it would be wise to first verify the hash of the VirtualBox installer exe just to be sure it's not corrupt or compromised. virtualbox.org/download/hashes/4.3.20/SHA256SUMS – misha256 Feb 1 '15 at 19:12
  • it still doesn't work see my edit – qballer Feb 1 '15 at 19:47
0

Note, I realize this question is a month old or so, but it applied then and applies in general:

Win 10 is currently beta/preview software, and as such you should be aiming to use the latest version of VB to ensure it's got the most compatibility. 4.3.18 is old (released 10-10-2014, ~4 months before your post), as of today they are currently on 4.3.24 (released on Mar 2, 2015). Try that version (or whatever's the latest offered when you get there).

See: https://www.virtualbox.org/wiki/Changelog

For example in version 4.3.22's notes (Feb. 12, 2015):

Windows Additions: some fixes for recent Windows 10 Previews

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.