5

I've tried to look into everything I know of but this has stymied me.

I have a Lenovo Thinkpad Edge 15" currently running Windows 7. The laptop will not enter sleep mode when I close the lid. When I close the lid, all it does is turn off the screen and lock my Windows session (requiring a password prompt when I open it again). But it does not enter sleep. It doesn't matter if I'm plugged into the wall or not.

I have tried: Checking the power settings. I have it set to sleep when I close the laptop lid regardless of whether I'm on battery power or plugged in. Windows power settings

Checking Lenovo's power control panel (which should be reflected in Windows' own settings anyway). Lenovo power settings

Checking for anything that prevents it from sleeping after it failed to sleep. powercfg /requests

Checking the BIOS (there was nothing indicating that sleep mode was disabled).

Trying to enter sleep using other methods:

  • Windows will enter sleep automatically if I leave the laptop powered on and idle for a long time.
  • Windows will enter sleep if I click the Sleep option in the start menu.

Closing the laptop lid when not logged in also resulted in the same behavior, so it doesn't matter if I'm logged in or not.

I also saw nothing in the Event Viewer indicating that any system errors occurred when it attempted to enter sleep mode.

What else can I try?

P.S.: Up until very recently, I had Debian installed on this machine. I wiped that and restored the same Windows 7 image I had made prior to installing Debian. On Debian, it was able to sleep the laptop by closing the lid. On the same Windows installation prior to me installing Debian, I was able to as well, from what I recall. This is the same Windows installation that came pre-loaded with the laptop. It is otherwise well maintained, as far as I can tell. I have been trying to keep it clean, as the laptop is 5 years old and can slow down significantly if I don't pay attention.

  • 1
    You should probably post that as an answer, rather than than editing your question. Its perfectly fine to post a detailed answer but not select it as the right now. – Journeyman Geek Feb 6 '16 at 6:54
8

There is another setting you could check.

other close lid options

See Control Panel => Hardware and Sound => Power Options => Edit Plan Settings and from there Change advanced power settings => Power buttons and lid.

| improve this answer | |
  • Yes, those were both set to "Do nothing". Changing it doesn't seem to take, probably because of the Lenovo Power Manager. Changed it to "sleep" and it now does so. (Why the heck would it have two conflicting options like that?) Changing it didn't take. I found there was similarly the same setting in Lenovo's Power Manager, under Global Settings. I made sure it was set there and disabled Enable InstantResume and now it works! Thanks for the help! – Ben Richards Feb 2 '15 at 5:12
0

There is a switch involved in the hinge mechanism that tells the PC to go to sleep. It could be broken.

| improve this answer | |
  • 8
    This answer might be helpful if you explained in detail how to confirm if the switch was broken or not. – Ramhound Feb 6 '16 at 2:58
  • 1
    Well since the laptop closes the session when closing the lid, it cannot be that, because it still detects something – Tofandel Aug 1 '17 at 0:57
0

I found the solution. Like @ott--'s answer stated, there is another setting hidden that can potentially contradict the settings I checked below (oddly enough). They didn't take because the Lenovo Power Manager takes precedence. I found this under the Global Settings tab, which similarly can contradict and I suppose override whatever the individual plans say. Lenovo Power Manager Global Settings

I had it set to sleep on lid close, but the option called "Enable InstantResume" was checked, which I suppose held it off from going to full standby. I unchecked that option and now it's going to standby as expected!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.